Calendar two way sync

I succcessfully imported my Google contacts, and they sync both ways between phone and nextcloud. The calendar, on the other hand, will only sync from the cloud to the phone, not the other way around. My calendar on the phone only has the one configured, and it is shown as Account Type /e/.

The import was done on the phone, not on the web interface. I see an import button on the latter, but if I import that way, will I be duping everything on the phone? I can’t see any way to delete the phone calendar first.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Update… I looked at the sync settings through Settings → Accounts → /e/ → Account Sync and noticed it had only synced when I set it up. I toggled it off and back on again. After a period of (attempted) activity, I got a notification titled “Personal” HTTP server error - HTTP 404 Not Found.

Another update, hopefully my (now solved) problem may help others…

Overnight, the http 404 error seemed to have gone away by itself, but still no syncing from phone to cloud. Couldn’t see how to delete a whole calendar, and I found mention of deleting accounts and starting over. I wanted to change my initial username anyway, and since renaming was not an option, created a new account. Deleted the old account on the phone.

I imported my contacts from a Gmail exported vcf into the new account’s nextcloud. Worked well. I then tried importing both a Gmail export and a Thunderbird ics export of my calendar. Nada. Read around some more and noticed somebody else mentioning browser as possible culprit. Mine was Opera (not now… read later about the once-great having been acquired by Chinese in 2016 and now privacy concerns, so Brave is new default). Fired up Firefox and tried to import the TBird ics. Nothing apparently happened, but when I clicked on Import, expecting to see the big blue Import button, it had been replaced by a blue progress bar. Moving dreadfully slowly it was, but moving it was. After a hundred years or so it completed. A message briefly popped up at the top right of the screen notifying me that “import partially failed. imported 1334 of 2xxx” (I wasn’t fast enough to read the whole thing). I can’t tell what is missing, as far as I can see everything within a couple of months appears to be there.

Went to the phone and added the new account. Contacts sync… check. Calendar sync… yup. Now for the Acid Test. Added test event to phone, and test contact. After a slightly longer than brief pause… … they both popped up in the cloud.

Happy camper here, hope this helps somebody else. My takeaways… import of Contacts and Calendar had to be initiated in the cloud first, not device, and (as far as Calendar) was browser sensitive. As for the missing items… if I can identify an event that was passed over I’ll publish the corresponding code.

Another idiosyncrasy I noticed with the calendar sync. I changed the calendar colour and added a new calendar, both in the web interface. The colour would not change on the phone, and the new calendar wouldn’t show up on the phone until I deleted the /e/ account in system settings and re-added it.

I have the same issue: The first import of calendars worked. But calendars added later in the cloud did not show up. Not even after manually requesting it.
After installing DAVx5 I was able to see these new calendars on my phone.
It is kind of absurd to install DAVx5 additionally as /e/OS’ account manager is a fork of it… But it helped.
What is the problem?
Why is updating the calendar list not working natively? (DAVx5 brings up a newly created additional calendar after requesting an update of the calendar list.)
Any help is welcome.