Camera app doesn't detect all phone cameras since v1.9 upgrade

I run /e/OS 1.9 on Samsung Galaxy s10+. This phone has 3 rear cameras/lenses: one with normal magnification, one with wide lens and one with long lens (zoom).

Until 1.9, the default camera app worked great and saw all 3 rear cameras. After I upgraded to 1.9, it stopped seeing my 3rd camera - it thinks I only have 2 cameras.

About say - build version: 1.50.1

Has anybody encountered this issue? Does anybody know if there is a way to force the app to re-detect the phone hardware?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

It seems /e/OS 1.10 update has fixed this issue - I’ve just upgraded last night and now I have 3 cameras again.

This may be a stupid question but how do you know if all the cameras are detected? I’m currently using a Redmi note 9 which has 4 rear cameras. Thanks in advance.

I know how many cameras my phone model has, and in the camera app, you have a “Lens 1” label. If you tap on it, it will cycle through all the available/detected cameras (either front, or back, depending on which one you’re using at the time).

There may be more visible lenses, than you have ‘cameras’ on more recent mobiles.
They are used in clever combinations to enhance the picture quality.
So, checking how many cameras the mobile has with the manufacturer and then cycling through the lenses in the app, should tell you if the app sees all of them.

Because those apps on custom ROMs can’t do the ‘clever combinations’ of the original app on the stock firmware, picture quality is very often not the same, unfortunately. For this reason people install and test other camera apps. Which may be worthwhile, if you converted a top of the line phone and are keen on picture quality.

1 Like