Camera: image remains dark when the exposure is manually changed

Hi folks,
I recently installed (successfully) /e/OS on my new FP5. Big Thanks to the eOS support and dev team

Before writing a bug report, I just want to describe in this forum my problem, maybe I missed a thing:

I opened the camera app that comes with e OS, played around with the camera settings, especially with the exposure (ISO). Everything worked as expected, ISO auto function was working, manual changing of exposure value was working (with front and “selfie” lens). After closing and reopening the camera app the image stayed dark. With ISO auto and by manual changes of the exposure value the image stayed dark, both with front and selfie lens.
I can definitely exclude a malfunction of the camera hardware. Installed a different camera app from the APP lounge to exclude that error (“Camera”, com.photo.android.camera, version 5.9.3). Image exposure works well, auto as well manual adjusting. With both lenses.
I’ve got pretty the same malfunction of the image exposure with the “Open Camera” APP (version 1.52).

… and yes, I did a reboot of the Phone :wink:

So for now, the preinstalled camera app is unusable
Is there anybody with the same issue? Does anybody have a hint to solve this problem?

thanks in advance and greetings from germany :slight_smile:

(/e/OS version: 1.17-t-20231109350751-stable-FP5)

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I suggest to try open the Camera app > Settings, (icon top right) > Scroll to bottom > Settings manager > Reset settings.

thank you @aibd for your prompt answer.
Just did the reset of the settings as you suggested. Worked at the beginning, but the problem (dark image) occurred again.

You might also try Settings > Apps and notifications > See all apps > Camera > Storage & cache > Clear storage | clear cache.

I wonder if you can tell whether automatic adjustment or any particular setting change causes the problem.

On my Samsung I have felt that coping with low light seems especially likely to cause a “lock up” of settings. I much more frequently use Secure Camera from GrapheneOS.

Cleared the storage … same behavior

I try to explain every step I did:
cleared the storage of the camera app, opened the app, disable max screene brigthness … so far the current image exposure works good in auto mode … I adjusted the exposure value manually, works also, closed the app and reopened it, the current image occures as dark as with a EV like -4, but the exposure has the value 0. Auto ISO does not change anything and also manual adjusting

I have the same experience with the opencamera app.
resetting settings or clearing storage help initially but not for the longtime

Also had the idea the disabling of the max screene brigthness could have something to do with that, but it showed the same behavior with the max screene brigthness enabled

and thanks for the Secure Camera hint. this app works good so far :slight_smile: