Camera on Samsung Galaxy S9+ not saving photos

I have a Samsung Galaxy S9 purchased from the /e/ store, preloaded with the /e/ os.
The camera will take the photo but when you open the gallery to look at it there is a file name shown but nothing but a blank white square for the image.

When I first purchased the phone the camera worked fine. Later on it would show nothing or the blank white square but if I checked it after a while the image would show. Now the image never shows.

I can’t trace the origin of the problem to a software update or a certain time because I actually don’t use the camera very much but it would be nice if it worked when I did.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I have a similar issue with my S9 and it seems to be related to refreshing the gallery. After I take a photo I have the same behaviour you’re describing but after a phone restart the image is displayed. On my device this seems related to the gallery app and I’ve installed a different one e.g. Simple gallery pro from fdroid. That worked for me.

Installing a different gallery app worked for me too. Thanks for the tip.