Camera terribly slow in FP3

Hey everyone,

I just ordered a new Fairphone 3 with pre-installed /e/. So far, everything works nicely, except the camera. Whenever I try to take a picture, it takes several seconds. Also, the pictures are shaky when there is only a moderate movement.

As I am using my smartphone to take pictures of my children, this is a huge no-go for me. The camera has to works fast and reliably. I even consider sending back the phone because oft this.

Is there anything I can do?

Thanks!

I agree the camera is not working very well. You can try some other camera’s. ‘Footej camera 2’ from Apps for example. Or a modded version of google camera, download here. I use this gcam mod, the picture quality is amazing compared to open camera.

1 Like

Would you mind trying open camera from f-droid? The codebase of /e/'s camera is similar but not identical to open camera.
Is the capture process and saving slow? Where are you saving the pictures? Internal memory or SD card. If SD card please test if saving to internal memory improves your situation.

I tried using OpenCamera and its the same problem. When I hit the button to take a picture it takes forever until the picture is actually taken. I habe the impression it is trying to focus, but changing to manual focus did not improve.

The gcam mod @andrelam mentioned however is much faster!

What you are describing sounds like you have HDR mode enabled, which takes several pictures and combines them into one for a better quality. This would explain the longer time taking pictures and the blurriness as all pictures should align perfectly.

Open the camera app, tap on the three dots at the top to reveal more options and choose “STD” for standard mode. Try this and see if it makes a difference, I’m leaving a couple of screenshots for reference:

1 Like

Hey, welcome in the forum :slight_smile:

So looks like you have several solutions.

  1. Use another Camera app (to Simple Camera for instance, available in the /e/ Apps installer).

  2. Keep it but :

    • Save pictures to Internal Storage (and maybe move them to SD card from time to time),
    • Disable options you don’t need (HDR or other process eating options),
    • Reduce the definition (the quality) of the pictures.

Thanks a lot!

Unfortunately turning off HDR didn’t do the trick for me and I am not using an external SD card. I really cannot understand why it is still slow.

However, I will have a look at Simple Camera.

Was the camera set to take pictures in HDR mode already? It’d be weird enough that turning this off doesn’t make a difference.

Perhaps your settings are out of place for some strange reason. Try to open the camera settings and at the bottom choose “Settings Manager > Reset settings”. This will set all camera settings back to the defaults. As you will see there, you can also save your current settings to a file and restore from it later, in case you’re concerned with losing your current setup.

I also have the FP3 with /e/ pre-installed so we should have the same version of everything. If you upload that file I’m happy to try it out on my phone and see if maybe I can spot the issue. For reference you can find the backup file using the Files app under Android/data/foundation.e.camera/files/backups.

If you are not comfortable sharing that information, review some of the settings that may consume processing power but that you may not actually need, as @Anonyme said.

  • Camera > Settings > More camera controls: Pause after taking photo

  • Camera > Settings > Photo settings: Image quality

  • Camera > Settings > Photo settings: Image format

  • Camera > Settings > Photo settings: RAW

  • Camera > Settings > Photo settings: Noise reduction original images

You shouldn’t need to lower the camera resolution, but image format can be an important factor. For most use cases JPEG is enough (the default quality at 90% is also fine), but disable RAW if you don’t intend to edit pictures with Photoshop. For noise reduction mode, don’t save original images either.

Thank you! Resetting to defaults and making your suggested changes made matters a little better - however it is still a bit slower than Simple Camera. I actually like Simple Camera so I think I can stick with that. :slight_smile:

1 Like

I actually experience the same thing. There is a number of seconds between pressing the button and the picture being taken. This does not seem related to the processing though, because the picture you actually get is from the end of that period. So there seems to be a delay before the picture is actually taken…

Apologies, there are lots of settings for a new user to work with. I discovered the issue was with “red eye” setting, which I had accidentally enabled. With “red eye” on it’s super slow, once disabled it works perfectly fine.

2 Likes

I have experienced the same issue as you all, and it seems indeed that the “red eye” feature slows it down even more.

An alternate solution is to use Footej Camera instead, the picture looks better and the delay is slightly shorter. Unfortunately, it’s not free of trackers (2 according to the Aurora Store).

I experience the same problem. Slow camera and pictures are of subpar quality on my FP3 with 3+ modules. I have the latest e.os build (e_FP3-userdebug 10 QQ3A.200805.001 eng.root.20210317.082242 dev-keys,stable-release). The abovementioned Gcam mod does not want to open for me, is there another one I could try?

(I don’t use it myself, so I can’t confirm.)

1 Like

I used an APK named PocoSv10.4.apk which is GCam 7.3.

Recently I installed a file named NGCam_7.4.104-v2.0_eng.apk which is GCam 7.4 and works great on my FP3 (Android 10, /e/ 0.15).

I downloaded both files here from the 7.3+ section.

1 Like

Thank you both! I ended up using the link provided by irrlicht that goes to the same place as AnotherElk gave me, I believe.

The Good news: wonderful pictures and quite snappy! I am sure that as I start to get to know the Gcam that I will improve it even further. Thank you so much for helping me out.

The bad news: when I want to open the last picture that I took (gallery) it wants to open it but it does not go to gallery. Instead, it is still the camera app with the sensor turned off (so the camera controls but the viewfinder is completely black). By hitting the ‘share arrow’ on top the pictures does open.

Is there a way to change the default gallery of Gcam in-app? Or another way to fix the problem?

Thanks again!

In GCam 7.4 is an option called “Use 3rdParty gallery” (or similar) which is off by default. I switched this on and it opens my Simple Gallery automatically. These options are one of the most idiotic things in GCam, you need a considerable time to find them. Another idiotic issue is that you propbably can’t change the folder where the pictures are saved. The pictures get always into the internal device memory.

2 Likes

Easy as that, thank you!

I will test what you said about changing the folder as soon as I can. For now I still have my other phone (S7 Edge Exynos) as my main phone and I will switch later.

Thank you again for being so helpful!

Since the last update of /e/, this modded version of google camera is not working.

The best one I found is the 7.4 v2.0 from here.

The latest (8.2) is also working well except that you can’t use Simple Gallery Pro directly because NGCam 8.2 requires 2 galleries to be installed — Google photos and third-party (Memoria, Gallery GO or any that worked in past versions).

This is not a bug. But Google prefer to change things. That’s why it is still recommended to use Google Photos instead of third-party gallery.