Can not install on Galaxy S5 duos


I would like to install /e/ on my smartphone but I have some issues.

My phone is a Galaxy S5 LTE Duos (G900FD) and it is supported by /e/

I follow this install process

and I am stuck at

adb sideload

with a message similar to “signature verification failed”

I enable USB debugging but was not able to perform an OEM unlock (can not find this option).
I did not install TWRP either.

I am running Debian 12

antoine@talos:~$ adb version
Android Debug Bridge version 1.0.41
Version 29.0.6-debian
Installed as /usr/lib/android-sdk/platform-tools/adb

hello @ant0ine, welcome to this forum.

there was no need to allow the unlock of the bootloader in develloper-option on this device generation, it was simply did when you install a custom-recovery-manager.

it is common as the build is not Samsung-Official, just don’t ask for a verification

1 Like

I had issues on upgrade to Debian 12 and there are some other reports of strange behaviour

First I would suggest that you really must be on latest platform-tools (not the older Debian version you are using).

Caution: The default adb installation on OS like Ubuntu can be outdated and can cause errors. We would recommend that linux distribution users ensure they use the installation process given here

However I suggest you are sure to retain Debian’s


and check that Debian already met this: Each user that wants to use ADB needs to be in the plugdev group. … add yourself to it using the following command:

sudo usermod -aG plugdev $LOGNAME


android-sdk-platform-tools-common is already installed and I am in the plugdev group

antoine@talos:~$ apt policy android-sdk-platform-tools-common
  Installé : 28.0.2+9
  Candidat : 28.0.2+9
 Table de version :
 *** 28.0.2+9 500
        500 bookworm/main amd64 Packages
        100 /var/lib/dpkg/status
antoine@talos:~$ groups
antoine cdrom floppy sudo audio dip video plugdev users netdev bluetooth lpadmin scanner

what should I do to not ask for verification ?

I tried once again to install /e/, here is the results

antoine@talos:/document/tel$ adb sideload 
Total xfer: 2.00x                                                  

my phone displays this message

E:failed to verify whole-file signature
E:signature verification failed
Installation aborted

I tried several times and I finally did it :slight_smile:

Here is what I did

1 > install twrp with heimdall (odin not available on Debian)

  • boot in download mode ( Volume Down + Home + Power)
  • then heimdall flash --RECOVERY twrp-3.7.0_9-0-klteduos.img

2 > install /e/ os

  • boot in recovery mode ( Volume Up + Home + Power.)
  • wipe data
  • select advanced > adb sideload
  • then adb sideload
1 Like

so, what was your solution ?

use TWRP instead of recovery-e ?
wipe /data that you missed during first attempt ?

well I think the solution was to use heimdall with TWRP