Can not upgrade Galaxy S9+ /e/OS build : T dev from e-1.15 to e-1.18

The problem is this. Bootloader 1.15 for developers was installed on the Galaxy S9+. Operating system version

Updating via the built-in menu did not work. So I downloaded the latest image and decided to install on top of this.

But I think the problem is that I made at least 2 mistakes before updating.
Before the update, I installed an alternative launcher (Final Interface) instead of the standard one and did not disable it.

I think it was necessary to switch the phone back to the standard screen launcher. Apparently that’s why I’ve now experienced an eternal reboot after the update.

The second mistake is that I did not install a new recovery before installing the latest firmware.

I don’t know how to install the latest recovery on Windows. I don’t remember how I installed it the first time.
Can someone tell me how to install the latest recovery? Or is this not necessary?

I can run the previous release of recovery Version 1.15

And install the latest update image from it, too, with a success of 1.00000, but after a restart, an eternal ball under the letter e jumps into the system. What should I do?
Please tell me.

I think the problem is that a third-party launcher (Final Interface) is installed in the system itself, and not the standard one. And therefore the operating system cannot start.

How to fix this problem?

Of course, a factory reset could solve the problem, but I don’t want to lose information on my smartphone. How can I reset the screen launcher to default settings without doing a full reset?

Or maybe the problem is not this, but that the recovery from version e-1.15 does not fit e-1.18?

I tried installing the firmware on e-1.15 via adb sideload. I can flash it with 1.0000 success, but I still can’t reset the launcher to default settings.

What to do?
Help me please.

If your alternative launcher (Final Interface) blocks your system, then reactivate /e/ BlissLauncher as a Start app:

Apps and notifications
App info
BlissLauncher > Advanced > Home app > YES

1 Like

I would love to activate it, but I can’t log in. The eternal letter e and the ball under it do not allow me to log in to change it to BlissLauncher , as you wrote.
Thank you 100 times for writing!
I thought no one would answer.

How to manually update the recovery or is there no need to do this? Is it already built into the latest firmware?

I tried to flash the latest firmware via adb sideloader using recovery version 1.15. I can flash it, but the recovery version does not change, and the operating system does not start.

Luckily I can enter recovery, but what should I do next?
Is it possible to activate BlissLauncher by changing the code in the latest firmware to force BlissLauncher to launch?

Can you use the ODIN 3 Flash tool under Windows? If yes, then Download first this version of Odin. More information will follow after your successful Odin installation.

1 Like

I will see now. I have just normal Odin. Old one Odin3_v3.14.1

yes. already done. Thank you
And now?

Okay, wait about 20 minutes. I’ll generate an e-recovery-v1.18.img.tar for you to flash with Odin3 and put it online for download.

1 Like



I have now switched the phone from recovery to download mode.
Downloading… Do not turn off target

Odin sees the phone on COM 3, which means everything is ready to update the firmware to e-1.18.

For some reason, on version e-1.15 it never showed me that there was an new update.
And there was always a message that there were no new updates.

I checked often both automatically and manually. But no updates were shown.

Therefore, I decided to update manually, but forgot to switch the phone to the standard BlissLauncher.

I hope your image will help me with this issue.

May the Universe protect you!

:new: recovery.tar.md5
generated from the official e-recovery recovery-e-1.18-t-20231210360971-dev-star2lte.img

1 Like

I will try right now.

Where should I install it? In the BL section?

Oh no, not BL = bootloader
Use tOdin AP slot (!)

See also /e/OS documentation

1 Like

Done but it’s still e bootloop after restart…

But I see Recovery version is 1.18!!!

I flash with him e-1.18 image now …

Do a manual update:

  1. install recovery.tar.md5 with Odin (see also /e/OS documentation)
  2. adb sideload

Done. I’m on e-1.18 recovery and image was flashed succesful with x1.0000 answer but I have still still e bootloop after restart

I think Final Interface still blocks start of updated OS normally

Clear the Cache (only) with e-recovery.

1 Like

I will try now. Thank You again!