Can t connect to always on VPN

‘advancerd privacy is set up to stay connected all the time but it can t connect right now. Your phone will use a public network untill it can reconnect to advanced privacy.’

I get this message daily. I m not very techni…what does it mean, what shall I do?

Thank you

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

have you tried to reboot the device…it is the first and easiest thing to do.

Thanks, well I get this message daily when I switch it on.

I think this is an Android 12 issue for all Android users, not just /e/. When you restart the phone, you have to go into Settings>Network>VPN and turn off always-on and turn it back on to reestablish a connection.

Thanks for the tip! But it s a lot of work!
Also how can I know if it works once I do?

So no real cure…

This sounds like the issue I’ve been having with Proton VPN since the v1.9s upgrade.

I’ve found that by turning off wi-fi a VPN connection is re-established using mobile data which then stays active when I turn wi-fi back on. When not using wi-fi turning mobile data off then back on works for me.

Not a solution but I find doing this from the pull-down menu a quicker work-around. May be worth a try.

I’ve an open issue in gitlab about this (

Thanks, I’ll check it out and try to follow the link/topic

I m still not sure: how do I see if it is on and working?


If you use a “what is my IP tool” - then you will see that the IP address displayed is not where you are actually located at that moment.

Thank you.
Now I see the VPN does NOT work, even if I switch it on/off as indicated in an earlier reply.

I guess I m left without VPN.
I have a FP4, and used the inbuild VPN.

I looked on Gitlab, but did not see a solution really.
Is there any?


Try again after you have installed an app from a VPN provider. For example ProtonVPN

Dave1 has tried this and has the same problem he said.
Also it wuld mean pay for a VPN while there is supposed to be an inbuilt one.

But thanks for suggestion.

just for clarity and You may be aware of that already:
the “inbuilt VPN” means traffic is routed via TOR-network, this “VPN” is due to the Hide My IP-module of eOS`s Advanced Privacy.
That may not exactly equal a paid (or else) VPN-Service as it would be commonly understood.
If you want to use a third-party VPN-service you need to switch off the Hide My IP-feature as there´s only one single interface for VPN in Android (and thus in eOS) that can be used by only one service or app at a time.
And: any service or app that utilizes this interface is considered being a “VPN” from the OS-perspective…

Do you have other apps installed that may have set up “VPN” as well and thus might interfere with AP by also trying to use the VPN-interface?
Have You tried switching off “always on” for the sake of failure analysis?

Yes, I have tried switching of, the always on, and always I get my real location.

But if you the screenshot attached, the weather map shows another location.
Also I did not hide the real IP address as I understood many features would not work.

Other apps which have VPN inbuilt, not that I know, unless it is inbuilt…

Not sure I understand all what you wrote, I will ask a friend to translate…
But thanks for looking into it.

1 Like

OK, I understand You do not use the "Hide My IP feature anyways …
In that case do not expect any funtion from the related “VPN” as it does nothing … it is only set up to be available just in case you want to use this specific AP-feature!

Instead make sure it is switched OFF in system settingsnetwork + internet → (expand) → VPN … as the trouble may be that you keep up (“ON”) the VPN (which is only there to allow function of the AP-feature) but switch OFF the AP-feature (which depends on this VPN-setup in system settings)… (is that understandable?)

IF you want to use real VPN instead, You need to get an app (+ service to log in) and the app will set up it´s own “VPN” in system settings …

Ok, thanks for the clarification.
I got it somehow. did it.
It indeed shows another location now.

Now I still need to learn
1/when to use hide Real IP.
2/what is the difference with another VPN, paid I guess ( with crypto coins which I dont have …yet)

It is complicated for non tech people, but one step at a time.

I do not want to bother everyone, but maybe there is a place where I can get this kind of info ( questions)
Because I thought VPN is inbuilt.

1 Like

no worries, this forum is full of people that are happy to help if they can. I know there are some VPN-knowledgeable people around as well.
Try the search function for VPN and don´t get discouraged, it might look complex…

definitely no need for that when it comes to VPN-services… there´s decent services that can be paid simply via e.g. credit card
my two cents: don´t jump on the first VPN-train unless you more or less know what You do. VPN is NOT the all purpose tool …

true, but it is not THAT complicated on the other hand. But as you have learned: it is easy to mix up the “VPN” in system settings with “VPN”- services (tunnel) (and You are not the first one…!)

The “VPN” in system settings is simply a name for the configuration /specific setup of the one single interface that android provides. It allows apps to direct and thus control(!) all internet-traffic through that interface so they can e.g. provide a VPN-tunnel-service.
Every app that wants to achieve something alike requires its own setup in system settings (“VPN”)
Advanced Privacy utilizes that interface to route the traffic trough TOR network in order to hide your real IP.
If you pay a company that provides a “VPN”-service you will have to install some app that will interact with the service “out there” (you will have to log in somehow I presume) and the app will ask permission to set up a “VPN”-configuration in system settings as well - because that´s the only way for it to control the traffic within the phone/OS.

I noticed in your screenshot you had Fake Location turned on. Did you fix your location by turning that off or some other method?

I think through ‘manage my location’, not sure anymore.