Cannot change device name

Hi there.

I tried to change the name of my FP3 from “FP3/FP3+” to something else. I changed it successfully under “Settings->About phone”. But as soon as I leave this menu afterwards, the initial name is restored.
Am I doing something completely wrong?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I’m afraid this is a known issue, I also have it since 0.17 or 0.18. There was an issue at Issues · e · GitLab with that, but I can’t seem to find it anymore. @Manoj do you have an idea of where it might be or if it got moved somewhere else?

EDIT: I found the link, but it wasn’t an issue, it was a community post: Device name resets to default maybe it’s worth creating an issue if it isn’t being tracked there.

weird, works on other devices than the FP3. Is it the preset name containing a slash?

when I try t change it utters…

V SettingsProvider: Notifying for 0: content://settings/global/device_name
I WifiService: getWifiApConfiguration uid=1000
I WifiService: setWifiApConfiguration uid=1000
E InputDispatcher: Window handle Window{a77ad4b u0} has no registered input channel
I bt_stack: [] hash_file: Disabled for multi-user
I bt_stack: [] write_checksum_file: Disabled for multi-user, since config changed removing checksums.
D AdapterProperties: Name is: FP3/FP3+ff
D BluetoothManagerService: Bluetooth Adapter name changed to FP3/FP3+ff
D BluetoothManagerService: Stored Bluetooth name: FP3/FP3+ff
V SettingsProvider: Notifying for 0: content://settings/secure/bluetooth_name

if I try to set content://settings/global/device_name and content://settings/secure/bluetooth_name manually those keys are set, but not read

adb shell settings put global device_name ffp321
adb shell settings put secure bluetooth_name ffp321

Places to look at are

You may also try “Device hostname” in Developer settings.

that works, though it will not be reflected in device_name in About Phone, the hostname will change.

Interestingly… changing the device_name in About Phone will set the bluetooth_name, but will not show it

I hope you are not seriously saying that it takes adb commands to set the hostname of the phone at /e/-OS :open_mouth:

no, developer options is GUI menu driven

Thanks for all these comments.
This means for me as a simple user and non-developer, that I cannot do anything at this point but using the developer menu?

So I tried and it works. As tcecyk said, the new device name is not shown in “About phone”, but the phone is registered in local network with the new name.

Thank you all

should’ve looked at the /e/ sources not upstream - there is specific handling of the FP3 model name, this needs rework… probably just altering the FP3 build options instead of handling it in the settings package