Cannot download apps, cannot see files in downloads, cannot save videos, everything is crashing

Hello there! So today I installed /e/ onto my Samsung Galaxy s8. I’m really not that big a fan of the default apps, and also of course I want yknow other apps. So I went into the /e/ store, and tried to download F-Droid (which the search couldn’t find, but I found later- besides the point) and Aurora. Whenever I tried to install it though, the app store would just crash. I tried downloading it through the web browser, and I’d get a popup saying

SD card not found.
Download to default folder?
(file icon) F-Droid.apk (editable field)
(folder icon) Downloads (editable field)

[_] Don’t show again
Cancel Download

I’d click “Download” and it would just pop back up again. if I tap on the “Downloads” field it says “not enough space”. The only thing i can do is hit cancel, which makes it go away.

I went to the files app to check on my storage, but both on the root(?) folder (SM-G950F), the Documents folder, and the Downloads folder, there is only a big hourglass with red sand in the bottom and the words “Can’t load content at the moment”. If I hit the 3 dot icon in the upper right, in Documents and SM-G950F the option for “get info” is greyed out. I can click it in Downloads but it just crashes the app.

I went into the Recorder app as an experiment, and tried to record the screen and my voice. It would let me hit the record button, but once I hit stop it would crash as well.

When I try to open Maps it says “One or more resource files are missing. Please reinstall the application.”

I can open and make new Tasks.
I can connect to wifi and use the web browser.
I can create and save contacts

If i try to take a photo, it says “failed to save photo”

That’s everything I’ve tried really so far. It is leading me to believe that I may have screwed up the installation of /e/, but I know I checked out of read-only mode in TWRP when I installed /e/, is there something else I missed? I wiped the phone, formated it into exFAT, all that jazz. Obviously I don’t have anything.

=edit 1: I also am unable to receive calls
=edit 2: i went back into TWRP, wiped and formatted just about everything, and went to the “install” tab (after putting the /e/ zip in the internal storage). When i click on the zip, it says “folder: /sdcard”. Does this mean it is trying to install onto a nonexistant SD card?
=edit2.5: i went into the file manager in TWRP and found /sdcard, it apparently is the name of what my PC calls simply “Internal Storage”

=edit 3: re-flashed. Still cannot take pictures or download apps or anything. opened up galery, got a new error: “No Storage
No external storage available”.
Plugging my phone into the PC, in This PC it doesn’t even show up as having space (it shows up as SM-G950F but there’s no bar, no “x GB free of x GB”)


Strange for a ‘stock app’: perhaps a problem during your /e/.img download…

It is a quirk of Android that the root of the system


This perhaps helps to confirm what you observed about Internal storage when viewed from your computer.(where sdcard represents the main user-writable partiton and external_sd represents the micro SD card :slight_smile: )

Your “first start wizard” should have set up you micro SD card properly.

Please can you confirm this detail first. I would strongly advise not to select “allow SD card as Internal storage”.

I thought and hoped that option had been discontinued.

The point is just to find out first if you have a micro SD card that is corrupted in some way, before dealing with the phone issue.

I can try redownloading the .img, let me try the other comment first though c: thanks!

“quirk” is certainly one way to call it lol. Its not a bug, its a feature and all that. Anyhoo.

I’m not sure what the first start wizard is? I don’t remember seeing anything like that, although it could be a background process or just refered to as something else. I can go ensure that I didn’t check the “allow SD” thing too. Also I do not have a mircro SD card in my phone at all which is what threw me for a loop

thank you!!

=edit 1: redownloaded /e/ img, Wiped and formatted the phone, installed /e/, did all that jazz. I am currently in the first time setup mode (getting your preferences, connecting to wifi, making a security pattern, etc etc) and I have not yet seen the “allow SD card as internal memory” option. Im going to go ahead and finish the setup for right now and see if the brand new download made a difference
=edit 2: it did not

Perhaps “first start wizard” = first time setup mode! lol.

So no micro SD card.

So you leave first time setup mode … and …

You have all the issues you mentioned in your OP?

Can you make a call? Although you don’t like Bliss, how functional / unfunctional is it?

Correct, still all the same stuff as in the original post. I cannot make calls.

All the apps launch fine (except Maps).

Is the issue that I don’t have a microSD card? That seems a little strange to me, but perhaps /e/ is hard coded to expect one, regardless of whether it’s used or not? I can try another install but this time put a small (8 gig) microSD in and see what happens. I’ll come back with the results and if i see anything different in TWRP.

Negative on SD card. Is not required.

Damn. Well. Hm. Guess we’ll see what else we can try

Perhaps check About phone.

Is your SIM card seen?

I am in About Phone and yes, the SIM is seen (phone number, Verizon, etc).

In Storage it also says 8.4 gigs used of 64 on Internal Storage, although it still doesn’t show up on my computer (I forgot you could view that through Settings, apologies)

is there a possibility that I may have gunked the TWRP installation up? And if so, how would I check it?

Is the device showing “Emergency calls only”?

What sort of computer, is your hard drive nearly full on that computer?

This may be why you cannot make calls:

1 Like

I had tried clicking on stuff and nothing had happened, i just clicked on SIM status. It says:

Mobile network state: connected
service state: out of service
signal strength: 0

damn. I just looked at the list; sure enough, Verizon in the US doesn’t work. That doesn’t explain the storage thing, but I think I will have to just go back to stock Android : / oh well. Thank you so so much for your help regardless!!!