Cannot flash twrp on xianomi MI A1

After several tests of my just recovered device I cannot flash TWRP on it. Tried with all the options in page TWRP official page even with the one @manoj posted in the Unofficial buld of pie but no one seems to work.

Any suggestion?

Do you have more info, what goes wrong when you try to flash TWRP? any logs, screenshots?

Not really. When “installed” TWRP the system goes blank.

MY MISTAKE, I’m an idiot.

I was trying to flash the twrp image instead of booting from it.

I realise my error just in the morning.

I’m deeply sorry. :worried::worried::worried:

1 Like

No need to apologize. We all have made such mistakes. No matter how many times you have flashed custom ROM’s it is always a bit scary.

1 Like

Its true @Manoj
Got a new problem. Even when I can flash the roms my device is allways in airplane mode even when the gui shows airplane mode is off. any ideas?
I think this can be solved using adb shell but don’t know.

Is your problem something like this issue mentioned on Gitlab

Also can you try and flash the latest MiA1 stock ROM - it will be Pie using MiFlash and check if your phone is back to normal.
Ensure when flashing with MiFlash you do not use the last option …i copied this image from the net …


As you can see there are three radio button below . Do not select the last ‘clean all and lock’ if you plan to flash /e/ or other custom ROM’s or TWRP after this. That options locks the bootloader. You can unlock it later but it will be a slightly long process.
The first option ‘clean all’ select that. It will clean up even your user data - backup if you need to.
Also copy paste the location where you store the Mi Stock ROM into the box on top and do not browse from the screen. Read somewhere than browse for the folder can create issues in MiFlash.
Try to flash the latest Mi A1 stock and check if the issue is resolved. Ideally you should first get everything working on stock before you try any other ROM.
Unfortunately you need a windows PC for all this :frowning:

OK, using android nougat doesn’t work. No Sim card detected.

The latest firmware keeps encrypting the device without password.

The device saw the sim but cannot use it. Still show airplane always on. :worried:

I Tried almost anything I read on the net. The most crazy ideas from Huauwei, Xianomi, Samsung and other trademarks. From Cleaning the cache to reinstaled directly from an old TWRP version. Nothing seems to work.

I take this screenshot just for documentación

I don’t need to translate the image.

Still in need of solution. :frowning_face:

====================Eureka! ==========================

10:40 P.M.

Reading a procedure in XDA I realize my phone doesn’t have IMEI’s. I can swear it is the problem
with my device. Will try to put the IMEI’s tmorrow. I’m… tired.

1 Like