Cannot install /e/ 1.2 update on Moto G5


I am using /e/ on my Moto G5 but struggle to install OS updates. I was also running out of space so I decided to install latest build (e-1.2) instead and start from scratch. When I flash latest a recovery image I get error message but I am still able to proceed and enter (latest) Recovery mode. Then when I try to ‘Apply update’ I get another error ‘This package requires firmware from an Android 8.1 based stock ROM build. Install completed with status 1. Installation aborted’. There’s no way how I can get it working. But according to my phone I am using Android 11 version. I then go back to my initial /e/ version (e-0.21) do the recovery flash + /e/ installation and everything is fine without any errors… until I wanna apply system updates, this time from within the phone menu. I can download latest build alright but when I try to install it I get the message ‘Note: The feature requires a compatible Recovery or updates’. And I am exactly where I was. Of course I also checked ‘How to update /e/’ but I only wish it’d be as easy. Any suggestions or help? I can always stick with /e/0.21 but I would rather have up-to-date version. Cheers.

Hi @hjfrhrthsw welcome to the /e/ forum.

I can think of one thing to rule out … can you be sure of what OS was installed on your device before you installed /e/?

To confirm that we are talking about this device Install /e/ on a Motorola Moto G5 - “cedric”. From Motorola Moto G5 - Specifications I read that its Android version was 7 with upgrades to 8 + 8.1 .

I will paste this from the install page

Caution: Do not install /e/OS on top of a higher version of stock OS. Before installing /e/OS ensure your device has the latest stock OS of the same version as /e/OS. If only lower versions of the stock are available then install the last available lower version before installing /e/OS. (My emphasis.)

Well, I have to admit I CANNOT be sure. It’s been a while since I installed /e/ OS and I don’t really remember the version of stock OS. I am somewhat 90% sure that I kept the stock OS fairly updated and was using Android 8.1 before I installed /e/. But as I said I really don’t remember. Any idea or tips? Or should I just flash /e/ 0.21 back on since that one works…

… but not a tip :slight_smile: … if you wanted to troubleshoot … /e/ image ROM download I see a variety of images and recoveries. | recovery-e-1.2-r-20220727206630-dev-cedric.img | recovery-e-1.1-r-20220628200015-dev-cedric.img | recovery-e-1.0-r-20220526188878-dev-cedric.img | recovery-e-0.23-r-20220404175826-dev-cedric.img | recovery-e-0.23-r-20220323172928-dev-cedric.img

Assuming you already have a 0.21 image maybe you could experiment with upgrades to see if it is the ROM or the /e/ Recovery which appears to break (just a thought). TWRP is not on our install pages (there may be a good reason for this … perhaps as this is an Android R build) but there was TWRP listed up to v 3.5 … perhaps someone with the device will share their experience.

This research might help inform your conclusions about this quite specific error

This package requires firmware from an Android 8.1 based stock ROM build.

Good luck

Done & SOLVED. So I tried all available images, including latest Lineage OS, with no luck. Then I decided to flash stock firmware (Android 8.1) and after that I was able to flash latest /e/ with no problem. So the whole episode of mine was (most likely) just about my phone not being up-to-date when I had installed /e/ OS in first place. Either way, thanks a lot for tips!