Cannot Install /e/OS - “Factory data reset” and “restarting” - LeEco S2

Hi All,

Well, as the title suggests, I cannot seem to reinstall /e/OS on my LeEco S2.

Earlier this year, I successfully installed version e-1-9q, and continued to upgrade till e.1.11q. For some reason, the UI crashed, and the bottom 4 icons disappeared, and any customisations and folders also disappeared. This prompted me to reinstall.

From recovery, I do a full wipe, and the reinstall is successful. I get the floating ‘e’ sign on reboot. But when it gets to the startup screen, the message “Factory data reset” and then “restarting” appears, and I go back to recovery.

I can install the latest LineageOS version for the device, and other untested ROMs also flash and boot successfully. But /e/OS only provides the above error.

I thought it may have been something to do with 1.11, so tried 1.9 - and the same error. Which is strange, as I installed it earlier this year without issue.

All searches online prove fruitless - is anyone able to advise? Or will I have to stick to an outdated LOS ROM for the device?

Thank you in advance.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Just a thought as there are no other comments … similar behaviour might be seen if there was a change of Android version going on.

In a quick search I do not find the LOS version you might be using, perhaps my search is too quick.

If it is the case that Android version change is involved, perhaps a further factory reset is required.

Have you tried installing the latest build from

Thank you for the replies.

No, the Android version for both remain as Android 10, or ‘Q’ - so there were no changes in that respect.

I had been checking that page for ages, but there was no June update - I can see it has now appeared in the time from my post to today. I will attempt to reinstall this version and will report back.

I remain on the LineageOS Android 10 for the timebeing.

As an update, I am still experiencing the above issue - my solution has been to flash an LOS 17 build first, then /e/OS (1.16q, from Oct 23 which is the latest at the time of writing). Otherwise, the same error as detailed in the original post appears.

While it seems stable, I’m still experiencing crashes of the Bliss Launcher, as detailed in the OP. Haven’t been able to determine why this happens, I’m just using an alternative one from the FDroid repo at the minute.

This topic was automatically closed after 180 days. New replies are no longer allowed.