Cannot install or update a paid app with App Lounge


I use a paid app on e/OS. I installed it quite long time ago. For this purpose I signed in with my Google account. But it appears that now, even if I am signed in with Google account, and that it is linked to microG, when I try to launch the update of the app, it tells me it cannot update. I also tried to install another paid app, but it does not work
To update or install a paid app, I need to install it on another android device, and then use an apk extractor, to transfer it to e/OS

I fear the link between App Lounge and the Google account is not totally effective, because when I sign in my Google account, they send me a code on this other Android device

What do I miss, please ?

Thank you for your help,


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

I should have precised : when I try to update, it says : “app update has failed due to a support rule (location, os, version…)”

Hmm, the support rule thing could apply to a number of things.
As far as location, do you have Advanced Privacy’s hide IP feature (Tor) on? That might put you somewhere other than where Google thinks you should be (??).

Or, if your /e/ device never had Google (Play Store?) on it it will not be on their list of ‘registered’ devices.

I really don’t know but I noticed in the past months a number of users are unable to install paid apps when it was possible previously. Not sure if anything has changed in App Lounge that may cause this.
I haven’t updated builds since A11.

Have you tried to install via Aurora Store? Try that and if it works…


Thank you for your answer @marcdw
It indeed works with Aurora!!

1 Like

Ah, then thst means there is something wrong with recent App Lounge build(s).

It will maybe be sorted at next update
Thanks again

I have the same issue with App Lounge on Oneplus 7T with /e/OS v1.18-t. I think it started beginning with /e/ v1.16 and didn’t change with updates to 1.17 and 1.18.
I’m also looking for an update of App Lounge to fix this.
Until then we have to update or install already purchased apps via Aurora (by the way which also updates /e/OS’s Maps app Magic Earth to a more recent version then the one bundled with /e/ :wink:).

It also offers to update “Google Play Services” but there is a conflict of packages
It is maybe the reason of the issue on App Lounge ?

It also offers to update “Google Play Services” but there is a conflict of packages
It is maybe the reason of the issue on App Lounge ?

No, I don’t think that because /e/OS comes without Google Play Services. Parts of the functionality of the Google Play Services are implemented by the microG framework in /e/OS. So I guess the microG services version is a little bit behind Google Play Services that makes Aurora thinks it has to update Google Play Services. But this can’t be installed since microG differs totally from that package and therefore it results in the error message.

I’ve run into this issue as well. I was able to update apps by installing the Aurora Store. However, I am still unable to install some apps that I had previously paid for through the Google Play Store.

Specifically, I was trying to install “Torque Pro.” I can open the app page in my web browser, and it shows that I can install it on my devices. Of course, my Fairphone 4 isn’t listed, but it’s enough to reassure me that I did indeed buy it.

Still, when I pull it up in the App Lounge or the Aurora Store, it only gives me the option to buy it for $4.95. I even tried doing that at one point, but it just gave me some error message about my session expiring. I assume that’s due to the lack of Google.

Is this a common problem? Is there a workaround that could help me? I used the Torque Pro app for car diagnostics with my old phone, so I would appreciate any help with this.

This topic was automatically closed after 90 days. New replies are no longer allowed.