Cannot make backup with TWRP on /e/ v1.0-20220527 - "0mb storage"

I recently upgraded my Samsung S9 from /e/v0.23 to /e/v1.0
The upgrade failed, leaving me with no other option than to Factory Reset /e/.
That worked, so after having reconfigure my phone, I now again have a working version of /e/.

Then, after some issues, I successfully reinstalled TWRP (v3.6.1_9-0) and tried to make a backup.
I can boot into TWRP but when preparing a backup, and more specifically ‘Select Storage’, there is no usable data volume.

I tried using the TWRP > Wipe > Advanced Wipe > Repair or Change File System > /data, but that only resulted the error “cannot mount /data volume”.

I found this thread, dating from 2018 until 2022, which indicates that it is not an /e/ issue as such. I did not try the suggestions presented in that thread as I’m pretty sure that this will result in me having to reconfigure my phone again. That is why I come here first to get find more background info.

Has this behavior to do with the fact that /e/ encrypted the partition when upgrading to v1?
Is it still possible to use TWRP for backup of /e/v1?
Does anyone know a fix that will not involve reconfiguring the phone again?

It sounds like this has more to do with known but irregular limitations of TWRP in Android 10 and up.

Can I suggest you first do small backups, I prefer a fully external device like thumbdrive, but SD should be ok.

/data perdition is particularly sensitive to this issue.

Your article suggests cleaning up /data. This might prove necessary. But I think it will depend on the device history. Did the phone previously receive the /e/ OTA upgrade?

The “cannot mount volume” will be due to encryption which is now default in Android 10.

When you know that you set no encryption password, you should

press Cancel at Enter password. (This is expected to pass default password.)

Again this might invite the “Wipe data” invitation!

Yes from from /e/v0.23 to /e/v1.0. And in doing so, I skipped one update. There we two updates listed as available: I immediately took the latest, being v1.0

Yes, good idea. I’ll focus on that first. Need to buy myself an SD card first :wink:

Skipping an update is not a problem.

I am thinking that you are experiencing the #ota-upgrade issue, which (when you read those threads) amounted for many in the need to wipe the /data partition due to it becoming encrypted, unknown to the user, I am afraid.

1 Like

Ok, that sounds like my best option to go forward is to reinstall /e/ using these instructions.

Any suggestion for a backup app/approach to backup/restore from inside /e/?

Most of the reports in #ota-upgrade did seem to be resolved by simply wiping data, it seemed to me. I understand that was the advice from to customers who reported the issue.

I find TWRP /data partition backups work to backup and restore fine. But I know that they will not transfer across Android versions or across devices.

I use that backup just for the convenience of being able to do random stuff with my device, but still find my phone as I had left it “last month”.

Anything “important” is backed up by the most suitable method for the app.

Right now you may have a different issue. If your /data partition was basically populated by Android 8, Oreo, a TWRP backup would be most unlikely to work on Android 10.

Backups made “in app” may transfer ok, depends on app?

Thx for that link. Interesting reading there.

Yes, my thoughts exactly. The first/short glance I had on /e/-recovery did not seem to make those backups easily. But I can be wrong.