Cannot make phone calls on Mi10T

Hi all,

I installed e-0.18-r-20210901133005-dev-apollo on my Mi10T device. Everything seems to be working correctly, except making a phone call fails (from both SIMs, different networks). The phone app tries to make the call, but the call is immediately ended (no connection being made or attempted). Does anybody have any clue if this is caused by a specific setting or that this is just a bug?

Thanks in advance.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Pl install Simple Dialer and check if you can make calls using it . We had a bug in another device where calls were not audible, wanted to check if this is a regression of that issue.

Unfortunately, using SImple Dialer, it behaves identically: call is ended immediately.

Hello @Manoj, @hatemp,
I have installed the same build on my mi10t appolon device and I have the same behavior with both e-os native dialer and/or with simple dialer. :woozy_face:

If you need logs or manipulation for testing or bug tracking purpose tell me.

I have make some try in order to clarify the issue, but infortunately no real success:
So I try:

  • e-0.18-r-20210901133005-dev-apollon.zip / recovery-e-0.18-r-20210901133005-dev-apollon.img
  • lineage-18.1-20211101-microG-apollon.zip / lineage-18.1-20211101-microG-apollon-recovery.img
  • lineage-18.1-20211204-nightly-apollon-signed.zip / lineage-18.1-20211204-recovery-apollon.img

I make a full wipe of both cache, data and system partition before both of the 3 install, but in every case no possibility to make a call…
It seems that the issue is in Lineage and propagate in both lineage+microG and e-os.

Hoping it will be fixed before Christmas (the Mi10T should be a christmas present :disappointed_relieved:…)

I ultimately fixed it by flashing the Mi10T with the newest Xiaomi image. Then I followed the procedure to put the (in my case the MicroG appolon LineageOS) image again on the device. After that, the phone calls worked, incoming as well as outgoing.

I went for LineageOS since the image was a bit newer and I wanted to test that the newest version solved the problem. Initially (with the off-fabric original Xiaomi image) it behaved the same as /e/-os. After the above procedure I got it working. I recon that /e/ will behave identically, but in my case I stayed with LineageOS and did some de-googling myself.

Note, that in case you have (like me) multiple SIMs in your device, the default SMS app did not work like expected (could not select the SIM to use, could not send any SMS with it), but changing that app to SMS Messenger solved that problem.

Thanks a lot @hatemp ,
Your message is a light in the night for me. Today the phone is back with its Xiaomi image and works fine.
Can you, please confirm the release you have used:
Xiaomi rom-> MIUI:12.5.7 - Android:11RKQ1.200826.002 - (my today setup)
LOS+MicroG rom : Recovery:lineage-18.1-20211101-microG-apollon-recovery.img - OS:lineage-18.1-20211101-microG-apollon.zip - (my future, hopefully working - setup)

Thanks for your advice about the multiple SIM issue, I’ll put only one as a starting try.
I’ll make another try in the very next hours but I want to avoid others unsuccessfull try, cause it becomes a little bit boring.
Last question, your post is a little unclear for me: Do you have make a try with /e/ after flashing the last Xiaomi rom or do you just suppose it was also working. Please could you confirm.
Another time, thanks a lot.

So the phone is now working fine (or seems to be) with e-0.18-r-20210901133005-dev-apollon.zip.

The booting time is very reduced compare to the time taken in the buggy install. So it looks like a timeout during driver init.
Basically I don’t understand why I have to reinstall the Xiaomi files to fix my issues because before starting to flash anything I check if the phone was up to date, and upload the last system release.

Nevertheless I’m glad, my christmas present is ok for offering :grin: :grin: