Cannot send MMS - Fairphone 5/e/OS 1.21

I got a new tele provider this Monday. I’m not sure if it’s correlated but on Wednesday I realised that I cannot send MMS. I will contact them but the plan is definitely including MMS, so not sure what the problem is. But very annoying

I tried to search the forum to see if others have had the same problem, and they did, but it was some years ago, and I didn’t understand how / if they solved it.

Someone suggested to use another message-app, so I tried that without succeeding.

Someone said that if I turned Mobil data off, the button for MMS-,essages would appear, and it did. I turned it on, but it didn’t help. Not sure whether it would work for me to have the mobil data turned off either, to be honest I don’t think that many of these functions are very well described.

I hope that some one has a suggestion because this is not really working for me…

Regain your privacy! Adopt /e/OS the unGoogled mobile OS and online servicesphone

your mobile provider sim has 2 IDs (mcc / mnc) to match an “apn” config that is then used to setup the mms address. There’s tons of threads on mms if you follow the topic tag. It’d be worthwhile to compare the APN settings that are chosen by the device vs. what the provider is suggesting in their help pages.

If the apn config is proper and mms work, there are still some conditions on size that can play a role in delivery (there was one fp5+mms match on that).

Thanks for your reply! I searched for APN and it guided me to access points. Not sure why there are more than one, but they all are set to the same mnc and mcc as what is stated on the provider’s website. So I guess this wasn’t it.

Another tag you might search is apn . There are many additional details to be defined within the Access Point Names.

Different carriers do it differently but I suggest asking the carrier to send the correct APN direct to the device.

Other carriers have been reported to get the right result by carrying out what they have called “APN reset”. (Perhaps just the same thing, but in my experience the call handler cannot do this and has to send the request to another department!)

Ok, thanks, I have written to them, so will see what happens…