Cannot send photos in texts

My network provider is 3 uk (Smarty Mobile) and I am using the latest (June 2023) e/OS version.

Smarty offer this advice I suggest you check the settings against what you find at

Settings > Network and internet > Mobile network > Advanced > Access point names.

The details must be an exact match !

There is a support channel mentioned in the above link. There is also a Smarty forum where your issue was raised

You already tried radically adjusting image size but a limit of

the limit is about 300Kb

is specifically mentioned.

Good luck


Iain you are an absolute star.

I changed the APN details as advised and now - after so many, many months - I can send attachments and photos via text.

I can’t thank you enough Iain … but thank you so very much.

Very best wishes


Thanks tcecyk, you were correct re bad APN setting. Email from Iain later suggesting changing APN setting with instructions on what to. Now I’m able to send attachments and photos via texts. Thank you both very much.

Problem now fixed. Bad APN settings for my provider. See the last post from Iain in this thread. It may work for you.


cool this got finally settled! mms still seems to be helpful.

Do you remember in what detail your settings differed before changing them according to Iains link?

the apns-conf.xml settings /e/-R has atm aren’t much different from that link - is resolved to the ip though. I wonder if you have a different mcc/mnc pair that didn’t choose that profile, or it did choose it, and the apn name attribute ‘’ was the issue:

<apn carrier="3 MMS" mcc="234" mnc="20" apn="" proxy="" port="" user="" password="" mmsc="" mmsproxy="" mmsport="8799" type="mms" />

Finally, yes thanks to you all!

For some reason there was not an option to view or to edit the APN settings. The only options allowed were to go back to default settings (still didn’t work) or to create new APN settings (all blank fields) which I did, so I don’t know what they were originally.

For a long time I was able to send attachments via the same messaging app on this phone, but for some unknown reasons the APN settings must have changed. I’ve been with my current provider for many years, so that hadn’t changed.

Sorry I haven’t got the info.

1 Like