Cannot send photos in texts

Hi, not sure if I am in the right place for troubleshooting? I cannot send photos via my text messages. The message info when I click of the photo in the sms/mms is ‘insert-token-address’. I could send photos at one time but can no longer do so. Can anyone in the community please help me resolve this problem. Thank you.

I had this same issue with the built in QKSMS app on Iode which is also a privacy focused lineage fork. I never did have the opportunity of time to screw around finding a solution during that short period and simply opted to try another ROM due to a long list of issues that piled up making the experience terrible. Image sending worked for about a month then mysteriously stopped.

Wish you luck on a fix.

Is sending MMS still supported by your provider? Some providers plan to stop sending MMS finally (or did also realize this, don’t know).


I have the same issue for months. If someone can provide help…

You may try another app to check if your problem is related to QKSMS (or /e/ fork).
For example: GitHub - SimpleMobileTools/Simple-SMS-Messenger: An easy and quick way of managing SMS and MMS messages without ads.


Hi, thanks very much for your reply and suggestion. I have tried installing other messengers and the one you suggest, but they still have the same problem of not being able to send photos (re 'insert-address-token)

Hi, thanks for your reply. I’ve tried installing many other messenger apps but so far all have the same problem (insert-address-token) and cannot send photos.

Are your photos stored in internal phone memory, or on a SDCard ?

On the Internal phone memory

Maybe you can try to reset Message app, it is simple and quite safe.
Go to Settings, Apps, open Message settings. Then Force stop, go to Storage, clear cache then storage.
Then launch the app again from your launcher, it should synchronize against Android database (if it doesn’t, you can trigger a manual sync in app’s Settings).

Still sounds like a provider thing. Can other people send images over this provider? (Or: Can you receive images from other people?)

1 Like

Some interesting reading here: MMS don't seem to get sent · Issue #1528 · moezbhatti/qksms · GitHub

Very often the problems of sending photos by MMS come from a bad setting of the APN.
There are a lot of topics about this on the forum:


Yes, I think they can. I’ll have to check though.

Thank you for the info. Unfortunately this does not work either

qksms / Messages allows to set a file size limit it will try to reach with compression - a user suggested to go with conservative 600KB and go from there - Default Message SMS app fails to send photos - #2 by tcecyk

1 Like

Hi Tcecyk, thanks for your message. Just tried 600kb and even 100kb photos but unfortunately it doesn’t work. The info in the photos I try to send still reads:
Back to the drawing board I guess. Thanks again

then I can’t think of another reason as my previous repliers -

bad setting of the APN

or the provider outright declining MMS attachments


Thank you again.

Best wishes


because noone asked yet - could you state your carrier / provider network and current /e/ version from the about phone menu ?