Cannot switch slots

I have a fresh installation of /e/ on a second hand Fairphone 3. Because I wanted to install TWRP and Magisk on both slots I tried to switch slots with fastboot. No matter whether the bootloader is locked or unlocked, whether I have TWRP and Magisk installed on one slot already or reinstalled fresh /e/ completely, each time I want to switch from the slot that was active while installing /e/, booting the other slot ends up in a e recovery screen:

Can’t load Android system. Your data may be corrupt. If you continue to get this message, you may need to perform a factory data reset and erase all user data.

I tried everything: factory reset, reinstall /e/ on the not working slot, unlock, lock the bootloader, install /e/ with active slot A, install /e/ with active slot B. Nothing helps. I can boot one slot, not the other. Twice after many failed boot attempts I could start the other slot, but only once. Then the problem recurred.
I can return to the previously active slot with fastboot and the system boots from that slot. So data cannot be corrupt. But what else?

What causes this issue? How can I fix it?

While I don’t know how to fix your problem, my main question is: why?

As far as I’m aware, the reason the Fairphone has 2 slots is so that updates get installed to the other slot and then the phone switches to that slot, so that if an update causes the system to not boot you can go back to before the update.

Regarding the topic title … Apparently you can switch slots, you “just” can’t boot the other one successfully. Call me pedantic :slight_smile: .

Regarding installing on both slots … I think the only way to really force and see what’s happening is to install manually while forcing the slot by appending every partition name with the respective slot when flashing.
So you would install manually and flash every partition name appended with “_a”, then install manually and flash every partition name appended with “_b”. Did you do it this way?
And while you’re factory resetting anyway, it can’t hurt to format the data partition with all the stuff you had going on. Wiping deletes files, but the directory structure might stay there (without files in it), so perhaps you want to format for a really clean slate before installing.

1 Like

I thought I had to install Magisk and TWRP to both slots but meanwhile found out that this is not necessary.
Nevertheless I thought the two slots allow to switch manually with fastboot if necessary. That is what I tested. With Fairphone OS I can switch forth and back as often as I like - until I made the first OTA update. Then the phone switched to the updated slot, of course, and manually switching the slot back caused the same error.
Did I understand it wrong? Is it not possible to switch the slots manually any time?

Of course you are right about the topic. :wink: Unfortunately I cannot edit it any more today.

To test I installed Fairphone OS and before formatted data as you suggested. In the end it did not make a difference (see my answer above). So I still wonder how switching slots manually is meant and works.