Can't add ecloud account to /e/OS

I’m using /e/OS 0.19 on a Fairphone 3+ and I’m unable to add my ecloud account in the settings. I get an error message that would translate into English as something like “No access to CalDAV or CardDAV service” (exact message in French is "Aucun accès possible au service CalDAV ou CardDAV). I paste the full log below.

A few facts that may be of importance :

  • I tried ecloud a few weeks ago, I was able to add it to my /e/OS install (same phone, but /e/OS 0.17 or 0.18). I was not satisfied with the features at the time and removed it (for my use, it lacked calendar sharing that is now available, thanks for that !)
  • I have no issue logging in to the web app
  • I’m using a password manager, so there is 0% chance I typed the password wrong (I’ve tried multiple times, anyway)

Thanks for your help

(logs deleted)

I just realized I add enabled two-step authentication (TOTP). It seems accounts settings can’t connect to an ecloud account usint TOTP. I disabled it and it fixes my issue. You can delete it. Sorry.

if you enable 2fa / totp you can use app-specific credentials (issued in the web settings → security) to still continue to use 2fa for the web login.

You probably want to delete your logs, they contain some personal info

Thanks for your answer and for the warning, I had not realized there was personal information in the logs.

in the three button menu there’s the “trashbin” symbol to properly delete. Editing leaves the history accessible, fyi

I did that for my second post and flagged OP for moderation (I can’t delete it). Thanks again for your help !