Can't boot to recovery, in order to install e on FP2 from ubuntu

I am trying to install e/OS on FP2 using my laptop with ubuntu. Apparently it has to be done from recovery mode, but I can’t get the phone to boot to recovery mode.

I have gone through these steps:

  • I allowed usb debugging
  • I installed twrp (tried with several different versions)
  • Fastboot oem unlock (it did not ask for confirmation on the phone, but it said OKAY in the terminal)
  • Checked that both adb and fastboot recognize the device
  • Checked that I have owner rights (and developer rights)
  • Tried force restarting (vol- and power button and vol+ and power button), removing battery for a few minutes, and factory reset

I have followed these instructions:
I get to “Installing /e/OS from recovery” point 2: “reboot into recovery mode”. And there I am stuck.

After rebooting (or trying to reboot) to recovery, it only says “No command” and then reboots again normally.

Keep Vol + pressed while starting or rebooting the phone to boot into recovery mode.

If this doesn’t boot into TWRP for you after flashing it, just flash TWRP again and make sure to boot right into it after flashing (important!).

If all else fails, you can boot TWRP with fastboot without flashing it …

1 Like

Keeping vol+ pressed down while starting does exactly the same, it just tries to go to recovery mode but only displays an android logo and the text “no command”.

I will try these other two methods in the next coming days.

That is the start screen of the Android stock recovery.
So recovery mode works, flashing TWRP didn’t. It is important to reboot directly into TWRP after flashing it so it can make itself resident.

1 Like

Sorry to contradict @AnotherElk, but I just tried (on an FP2 with the most recent Fairphone Open installed) and got into Android stock recovery straight by booting with power + volume up held.

However, I think at one point the procedure to boot into Recovery was slightly modified. When you see the “dead” Android on its back and “No command”, the buttons need to be pressed again, but in a different manner. If I recall it correctly, it was briefly HOLDING the power button and briefly PRESSING the volume up button. (Update: I was just able to recreate and confirm this button combination, although on an FP3 with Fairphone OS installed)

Where’s the contradiction?
Recent Fairphone Open OS uses the stock Android recovery, so you would get into stock Android recovery when booting into recovery mode.
I just booted a Fairphone 2 with LineageOS installed into recovery mode, and it got me into the LineageOS recovery.

I was referring to that intermediate stage of the dead Android, I don’t get to that stage on the FP2 here with standard AOSP recovery. Anyway, to fully get into AOSP recovery from the dead Android, hold power and press volume up.

No disagreement on TWRP. I absolutely second the following: :+1:

1 Like

And now I flashed TWRP to the recovery partition, rebooted directly into recovery - resulting in getting into the flashed TWRP, then rebooted again into recovery - resulting in getting into the flashed TWRP, so success - TWRP is now the recovery, the procedure should work.

Ah, thanks, now I get it. Seems I have yet to see this, so I didn’t understand.

1 Like


I did these steps again:

adb reboot bootloader
fastboot flash recovery twrp.img
fastboot reboot (immediately, but without some sort of key combination which may be needed to prevent the stock ROM from replacing twrp)

It still goes to “no command”. By holding the power button and pressing volume + once it goes to an android recovery menu, but I don’t know how if I can somehow install the twrp from here, or if this stock recovery is good enough to wipe everything clean and install e/OS?

I fixed it! I found this instruction:

…which had the secret information needed, that one has to have volume+ pressed in while doing the first reboot after flashing! Now it works! I’m so happy I will have a beer :smile:

1 Like

For others reading along or finding this via the search:

Regarding the secret … Once TWRP got flashed, TWRP is the recovery mode (TWRP = Team Win Recovery Project).
Booting into TWRP = booting into recovery = same method applies (keeping Volume + pressed when starting or rebooting the phone).