Cant get to isntall /e/OS on my Oneplus 6

Hi there,

The title already says most of it. Today I tried to install /e/Os on my Oneplus 6 but failed to boot into recovery and istall from there.

I followed the guide but without success. Install /e/OS on a OnePlus 6 - “enchilada”
I am stuck at “Temporarily booting a custom recovery using” at point 4.
When I start the phone it either goes directly into fastboot mode or goes briefly into recovery mode and then jumps directly into fastboot mode.

I don’t know if I have bricked my OP6 by trying to install postmarktOS and ubuntu touch.

It would be great if someone can help me and save me and my trusty OP6 :wink:

Cheers
KGOP6

Did you reinstall OxygenOS in the same Android version as your intended /e/OS before you started ?

The phone is not bricked if you still have fastboot.

No, i tryed flashing twrp (Download twrp-3.3.1-2-enchilada.img) becaus i dont know the version to be honest. But it didnt boot into it either with “fastboot flash boot” or with “fastboot boot”.

I think you are answering “No” to my first and primary question.

In this case I think you should now search for OxygenOS and install it by a fastboot method.

2 Likes

Oh yea sorry. I didnt reistall OxygenOS. I thought it could be recoverd with twrp.

I tryed following this guid just with the Oneplus 6 version.
([HOWTO] OnePlus 6T: Roll-back to stock OxygenOS ROM after a brick / being stuck in a loop)

Is this the right way? Since iam not sure becasue im pretty pretty new to this whole phone tinkering and got an error while doing the first line “fastboot flash aop_a images/aop.img”

Error:
$ fastboot flash aop_a images/aop.img
Sending ‘aop_a’ (180 KB) OKAY [ 0.016s]
Writing ‘aop_a’ FAILED (remote: 'Flashing is not allowed for Critical Partitions
')
fastboot: error: Command failed

The device state in the bootloader is currently unlocked.

@aibd Sorry for the late reply. I tryed doing it the above posted Guid again but with the same result.

Since i installed all availabele updates before i istalled postmarketOS i used the newest ROM from here: FastbootRoms - Browse /OnePlus 6 at SourceForge.net

I used: 10.3.6-OnePlus6Oxygen_22.J.48_OTA_048_all_2010042239_c0c1fee2ee-FASTBOOT.zip

Withe same outcome. Before i installed pmOS i enabeld USB debugging and unlocked the bootloader.

I dont really understand why the flashing is not allowed.

I am sure you are on the right path in getting the most recent version of Oxygen onto your device. I searched the problem of “Flashing is not allowed for Critical Partitions”.

As this question is important and really about recovering your device “to original OS” after “experimentation” I think you might search / ask

1 Like

Thanks for the reply. I posted the issue there too and going to replay here when i get any replys.

What was the last version of OOS that you had on the phone? This may be an important factor in deciding how to restore the device.

As far as I know Android 9 OOS is required as the base for UT. Is that what you had?

I dont know what version it was, i sadly didnt saved the version.

Before i installed pmOS i installed all available updates. So i guess it was version 10.3.6, since that was latest version i think.

Last OOS was Android 11.
Quick search finds this:
https://service.oneplus.com/in/search/search-detail?id=2097031&articleIndex=1

Sometimes when updating phone the updates don’t always ping through immediately one after the other so you are in the land of educated guesswork as to what you had.

The fastboot method of flashing as far as I can tell is to restore the device to previous android version, that is: not to downgrade or upgrade.

Method would be to download the appropriate OOS rom and extract it somewhere on pc, then open terminal in that folder and issue the commands outlined in the first section of Manual Flash of this XDA topic. The fastboot partitions section. Don’t flash persist as it says in the other post you linked to.

I know you already tried this method and maybe it just won’t work for you. I helped a friend restore his OP6 a while ago, see this post here. That was about a year ago. Recently he tried it again but the flashing script would just not work, it put the phone in qualcomm crashdump mode. The only solution in the end was to use msm flashing method…which needs windows and setting up of appropriate drivers etc. See this:

I’ve just had a thought and gone back over this thread again and it occurs to me another couple of things to try first.

Which eOS recovery did you try flashing at the very first step? Was it the latest S recovery?

Try an older R recovery.

To be honest i tryed so many images the past two weeks :wink:

So that we are talking about the same:

I use “fastboot flash recovery” and i usesd recovery-e-1.7-r-20230112250687-dev-enchilada.img

But it didnt work and this error camn up:

Sending ‘revovery’ (65536 KB) OKAY [ 1.647s]
Writing ‘revovery’ FAILED (remote: ‘(revovery_b) No such partition’)
fastboot: error: Command failed

Command should be

fastboot flash boot <recovery filename whatever it is here> 

then pwr off or unplug and manual boot recovery with vol down and pwr buttons.

then do the rest of the instructions step by step

I tryed that with twrp before and it didnt work.

I now tryed it with the eOs recovery with the command you suggested but it didnt work.

After the command my terminal displyed:
Sending ‘boot_b’ (65536 KB) OKAY [ 1.679s]
Writing ‘boot_b’ OKAY [ 0.284s]
Finished. Total time: 2.017s

Than i done as you said:

But with the same outcome as decribed above. When I start the phone it either goes directly into fastboot mode or goes briefly into recovery/boot mode and then jumps directly into fastboot mode again.

OK, well the last thing to cosider trying would be to change slots and try flashing recovery to that boot partition.

plugged in fastboot mode:

Double check which slot you are on

fastboot getvar current-slot 

cange slot to a

fastboot --set-active=a 

reboot bootloader

fastboot reboot bootloader 

then fastboot flash boot recovery again. See if that works

Tryed that before aswell since i read it in some post. I did it agin now with the eOS recovery but sadly the same outcome ;(

Oh b****r!
Looks like msm might be called for.
Anyway, good luck.

Big thanks to @aibd and @chrisrg for helping me out.

I got my OP6 to work. I used MSMTool to restore my phone. Than i reinstalled OxygenOS 10.3.8 and updated further to 11.1.2.2 From there is just used the by /e/OS provided guid (Install /e/OS on a OnePlus 6 - “enchilada”) form top to bottom.

Now iam gonna set it up and try it out in my day to day use and cut a little more Google out of my life. :wink:

Cheers
KGOP6

1 Like