Can't install on MotoG peregrine

I received a reconditioned Motorola Moto G 4g version - peregrine - and managed to unlock the bootloader as per install instructions on the /e/ wiki and after much difficulty finally got TWRP flashed as my recovery, but when I tried to use it to flash the latest peregrine for /e/ the operation stopped with this warning:

Detected filesystem ext4 for /dev/block/bootdevice/by-name/system
Cant install this package on top of incompatible data Try another package or run a factory reset
Updater process ended with Error: 7
I suppose this means I’ll have to flash a stock ROM for this model. If so, would this version on XDA-developers be adequate?
My phone came with Android v.5.1 pre-installed but I think the original model came with the Lollipop v.5.0.2 but the link above points to a rooted, debloated stock rom. Will this change anything and allow me to flash /e/ on top of it?

Have you tried to format data before flashing. I mean not only wipe. TWRP does have a optopn for formatting data. After format data you can flash e again and I hope it will boot.

1 Like

Thanks @Harvey186 I discovered the factory reset in TWRP and did this before installing /e/ which worked perfectly. I was looking for a stock rom flash which I didn’t fancy, but then realised what TWRP was capable of and this worked fine. Among the numerous attempts to flash my MotoG I finally found one instruction which enabled me to successfully install TWRP and that was simply to rename to long file name for peregrine version and put simply “twrp.img” and using fastboot this finally worked for me. The error message of “mismatched partitions” apparently doesn’t affect anything. Perhaps this might help someone else attempting to flash /e/ on a MotoG.


Just wanted to add further to my experience of installing /e/ on a Moto G “peregrine” version that everything is working well outside of the telephone tools as I’m still waiting for a new Sim card. But what particularly pleased me was that the update function works perfectly as it downloaded the most recent zip file checked it and then when I confirmed by tapping on Install, it rebooted into my TWRM Recovery, automatically started the patching of the system and then rebooted back into the normal /e/ interface - all without any need for manual installation as happens with my Galaxy Note2. Thumbs up to the programmers! :+1:

1 Like

Hi. It was getting ERROR 7 when I tried to install /e/ in Peregrine with TWRP 3.4.0-0. But it worked fine with 3.3.1-0.