Can't install T version on Moto G100

Hey there, I’m having troubles with installation on my new Moto G100.
Following the steps to the letter, I can install S version just fine, but I just can’t install T.
If I install the T version directly I have problems with the recovery: I don’t know if it’s broken or what’s the problem, but when I install it and reboot to recovery it goes in a boot loop.
So I tried to install the S version and then, from the recovery, update doing adb sideload of the T version. It finishes the installation process just fine, but when I reboot it enters in a boot loop just like with the recovery.
It’s weird since on the site I read that the Moto G100 supports the T version…does it yet?
I tried installing the same version of LineageOS and it works, so it have to be a problem with /e/OS, somehow…
Could anyone help me please?

Did you try twrp recovery instead. If you are incessant on using e recovery, i would use 1.16 to install then upgrade.

Hey all,

I am having issues with the installation of the T version on a G100 as well. Installing the S version is working fine.
When I use the files for T (1.19) instead of S I can get into the recovery boot but neither Linux nor Windows can identify the phone via adb. I used different ports and cables but did not get any further. I tried to boot on slot a and b but that has no impact in my case.
One time with great luck I could perform the sideload and T version booted on the device finally. Unfortunately the touchscreen wasn’t working with the new OS so I couldn’t get far.
Nevertheless installing the most recent LineageOS (lineage-20.0-20240116) can be performed without any issues. Is is booting and the touchscreen is working with LineageOS.

I also tried to install the T version 1.18 and 1.17. In these cases I can’t even enter the recovery boot. Phone is stuck in boot loop with these versions.
In addition i tried to sideload the e-T-1.19 with the recovery from Lineage. This try terminated with an error.

I feel your pain and I am running out of ideas to get e-T-1.19 working on this particular device.

I would appreciate any help or suggestion in this case as well as yak.

Did you check the sha356 or md5 to make sure it’s not corrupt.

You can flash without adb with twrp if

  1. You can download the .zip to an otg flash drive or
  2. Can boot into stock android and download .zip to internal storage

Just go to install and find .zip

I checked the sums and the files are not corrupt.

I tried TWRP (3.5.2_11.0) to install to the phone. Command line state that it was installed successful but the OS did not boot at all.

I will return to e-1.17-s and will try again when a newer T version will be released. Thanks for your help and the suggestion.

Side note:
TWRP had several issues when it came to recognize the storage (internal and external). With every boot in recovery to TWRP i needed to change the filesystem type (twice as it can be found on the web) and wipe the data to make the internal storage available. I did an “adb push” to get the zip-File to the phone as I could not make external storage available to the TWRP system. Nevertheless I was able to go to “Install”, choose the zip and start the installation.