Can't pick up incoming calls when screen is dark

I am using an /e/ GS 290, preinstalled, and I am liking it. However, there is a rather obnoxious bug: If the screen saver is on when a phone call comes in (which is almost always), the screen is not turned back on automatically. The phone rings, but remains dark. I can only press on one of the buttons at the side, which always cancels the call.

So I cannot pick up incoming calls!!!

This is a rather stupid bug for a phone. I had waited for the latest update, hoping that it would solve the bug. But no. Last update was “0.15-20210317106351”.

Any ideas what I could do?

I guess I have the same problem, which I haven’t reported yet, but were planning to inform support anyway. Just like you, I waited for the 0.15 update, but it is still the same.

No matter if the screen saver is active or not, when a call comes in, I feel the vibration and hear the sound, but no windows pops up, just like you explained. Well, sometimes it does and sometimes it doesn’t (see below). But I have a workaround. Still annoying, but better than nothing,

So when the screen saver is active and it stays dark, briefly (!) push the power button, your unlocking screen shows up, unlock, open the telephone app and try to call any number in the call history. A message shows up “Call not possible due to an incoming call” but also the window for your new call and you can accept the call.

What I have noticed: when the app is not opened, nothing pops up for sure. Once I open the app and leave it open, most of the times the window pops up I can accept the call right away…though not always. :man_shrugging:

Good to know one’s not alone! Actually I had also noticed that the bug is irregular: Sometimes the screen to pick up he call shows up, sometimes (most times) not. I sometimes have the impression that once I believe “OK, it works now”; the phone decides to let me down again. :smile:

I will look if I can also report that it depends on the dialer app being open. It’s pretty hard to debug, the whole problem…

Hello, thank you for your purchase and sorry for the issue you are facing.

Your issue might be the following one:

If you install “Simple Dialer” (or any other dialer app) and use it as default phone app, does it solve your issue?

2 Likes

In the Settings app does your phone have the option to answer call with volume button? Settings>System>Buttons>scroll down to Volume Buttons

2 Likes

I had installed Simple Dialer (Simple Mobile Tool) in Feb before the update from 0.13 to 0.15. This worked in terms of accepting a call, but I remember an issue regarding the interaction with the Contacts App, so I de-installed it back then. Furthermore, I prefer the /e/-OS default Phone App, because it doesn’t fill out the whole display when a call is incoming in the unlocked state. If this can be configured in Simple Dialer, I haven’t found the setting yet.

I re-installed Simple Dialer and Simple Contacts now. Nevertheless, I still regard installing Simple Dialer as a workaround so I hope this will be fixed in the future.

Please note, I install apps via F-Droid.

Hello,

no don’t worry we are still looking for fixing this issue.

To anyone who faces/faced this issue:

  1. do you have changed any default setting in the Phone app?
  2. do you have changed any setting related to notifications of the Phone app?

Don’t hesitate to reset the Phone app in case you have any doubt:

  • Settings > Apps & notifications > Phone > Storage & cache > Clear storage > OK.

Thanks! Installing the “Simple Dialer” App did the trick.

I also changed the settings so that using the volume button turns the screen on. This way, I could figure that the original dialer app is not opened at all. So that seems to be the problem. Installing the alternative app works, but I consider it a workaround.