Can't read mails anymore

I used the settings backup with regular k9 mail from f droid and disabled og mail app. Works.

Idk but as already said, that mail version has beta status. Maybe don’t use beta status software in e.

Then maybe don’t use /e/OS at all according to - F.A.Q - question “Is /e/OS stable?” :wink: .

(Hint: It currently says “we’re in beta stage at the moment”.)

Yeah OK. I guess yur right. =D

But I have to say e didn’t feel like beta software for me for a long time so I forgot I guess

1 Like

Isn’t it stable since v1 ?

My take would be that software nowadays can never be considered stable in the sense of the word outside of heavily regulated areas in this regard like e.g. aviation.

Apart from that, “stable” is a label you can slap on software things as you see fit.
And v1.0 is such a label, too. Did anything change fundamentally on the user front with /e/OS 1.0 regarding glitches, bugs and the like?

These labels serve as a kind of internal tags on one side, distinguishing one thing from the other in development, as well as on the other side they might be used for marketing or communication purposes.

Don’t take any functionality for granted, have a plan B for important use cases, and back up your important data often :wink: .


Strangely, the e-mail problem has reapparead after a couple of days, reason unknown! Even resetting the mail app is therefore only a temporary solution. I hope that the problem will be fixed in the next update. As a workaround, I still have K9 installed, which works as expected. (So there’s hope that the mail app will be fixed because it is based on K9 :wink: :slight_smile: )

EDIT: Well, I sent an e-mail for the first time after resetting the app, maybe this caused the problem? I don’t know.

Forget the Mail app. Use something else [1]. I did that two years ago when I noticed that the stock Mail app didn’t reconnect to the servers after flight mode and remained hanging in a zombie state until you noticed the mysterious quietness and had a look at it. (Meanwhile this bug seems to be solved.)

[1] Use the original K-9 or, if you want to make a step, Fairemail which is a very solid piece of software. I never had any problem with it since then.

Same situation impossible to read emails on same device (FFP4)
No solution yet…
I use k9mail for other purpose and dont want tomix my emails pro and perso

But you can have as many mail accounts as you want in a mail app. There’s no need to have more than this one mail app. And there’s still no mix at all, the servers will keep the received and sent mails very well. But this mail app should work then reliably.

Yes I hnow well I can do that thanks. Would you please let me organize my data as want ?
You seems to take all questions as an attack agains the project ! It’s not the point.
The fact is that there is a major bug on a major app it just has to be fixed.
Our community goal is that we can recommand eOS for any user as soon as possible, isn’t it ?
With such update issues it’s simply not even possible. With 700 Euros Phone it’s a pity (not in my case hopefully)
I do really like eOS I use it on my personnal and professionnal phones and I want them to work always better


No, not at all. Read what I wrote. I use the project and am happy it exists.

Yes, would be good. But in the last more than two years fixing bugs in forked apps has never been the most important thing here. I made several cases, about ten, a single one of them has been fixed, and not by repair but by reforking. Most of the others have been closed meanwhile “because of inactivity”.

My solution of these problems would be to remove these forked apps generally. There’s no need for them at all. Instead there should be a proper website which lists (and suggests) free, well known and well working apps for the basic categories (internet browser, mail client, calendar, messaging, navigation, multimedia, privacy). These forks have several evil disadvantages: they tend to be outdated, they bind people (I mean developers, testers, support) onto tasks they probably don’t understand in every aspect, and the benefit for the user is indeed absolutely zero.


OK as you explained it I understand your position yet. Thank you ! It’s more a debate with the project’s leaders I guess. I still believe that normal users simply expect the default app working well… It’s confusing when you receive a mobile device with preinstalled app you’d rather not use !

About the further back described issue, it’s suddenly working great again after a shutdown and restart (reboot did’nt fix) mail app on FP4

are you in a position to capture a debug log from the moment the Mail App switches/flickers back to the list view? I haven’t got a device I can upgrade to 1.18 atm to do this myself. I guess it’s easy to reproduce for anyone on 1.18. In any case I’d edit the issue title to describe how Mail misbehaves for people looking into the bugtracker later to see the behaviour is reported.

1 Like

Happy Christmas to all, and thanks to those who develop and document. I’m a year in with the OS, and it suits my needs pretty well. I did need a better camera, and will probably want to switch back to AT&T soon, so I upgraded to the Pixel 5.

Since my (clumsy) migration, I seem to have only one app that misbehaves. The default mail app will flicker, then return to the inbox view when I try to open an email. I tried deleting several old emails, which put things to rights for awhile, but the behavior started again.

I also attempted a “force stop” and a restart of the phone, which did not accomplish anything.

My Murena account works fine on the Windows dashboard and through a browser.

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

you’re struck by a bug described at Can't read mails anymore - the easiest workaround being setting up upstream k9mail

Ahh, thank you for the link. Ill look into the workaround. Or just grab my murena emails from my desktop for awhile.

Well, there was not much exploration to be done. All set up with k9mail.

Is this issue impacting all emails like gmail, etc. or is it specific to certain emails only?

I have combined two similar mail threads here to make it easy to track this issue.

Manoj, in my case it was only my emails.

Pl can you create an issue about this on gitlab. In case you do not have an account on gitlab use this guide

1 Like