Can't remove an APN from previous carrier, causing SMS failures

I’m in the US and recently changed MVNO carriers, both use T-Mobile networks. Lately I’ve had some SMS failures - failure on sending group texts, and texting photos. When this happens, I noticed that the APN has been switched back to the old carrier somehow, and I have to reselect the new/correct APN.

The bigger problem is that I cannot delete the old APN or any other of the APNs at all. In the upper right 3-dot menu, Save/Discard does nothing. I’ve tried rebooting w/ a couple of combinations, like with mobile data off, etc but I may have not found the combo that works, if that even does.

Is there a way to delete old APNs via other means? I’ve read some online that it’s not currently possible.

Phone is a Moto One 5G Ace with 1.8.1

I’dd suggest to try the following:

  • reboot the device without SIM card
  • use the Reset function (see below)
  • power off, put the SIM back, power on

Hey @smu44 ,
[thread hijack]

I have the same APNs. You using data only SIM?

Hi @marcdw,
No, this APN works for everything :smiley_cat:

@smu44 thank you - I tried your process. Because there was no sim, I could not even access the APN menu normally. I have an app called APN Settings which thankfully takes you directly to that menu which I was blocked out of.

Anyway, after resetting to default w/ no sim, then rebooting with the sim, nothing changed. The old APN is still there & the phone defaulted to it.

I am thinking this is a situation where the APN is somehow locked. I haven’t tried talking to the carrier’s tech support yet. Should I try the nuclear option and root, etc?

My phone is VoIP only, using for calls. Have a data-only SIM from them (apparently provided by KeepGo) that has the same exact list of APNs.
Was just curious. I take it Orange is a big provider out that aways.

1 Like

At first, I’d try to confirm mcc/mnc from you provider, then check against this file if there is no mismatch (ie 2 entries with your same values):
NB 1: assuming you’re using Android 12 there, please change branch accordingly.
NB 2: 1.8.1 is quite old, you may also compare with latest release for your Android version (ie

Then confirm with your device xml file (please see below to get your hands on it).

If you find any duplicate or error in xml file, I think you may:

  • at first, check/open an issue, so it may be corrected in future releases
  • in ADB root (not talking about rooting the entire device here :wink: ) locate the xml file, may be in something like /system/etc (sorry no time to check, if you need help locating the file I can check later)
  • if mounting system partition RW in Recovery is available to you, adb-pull file to PC, correct/delete lines in xml file (please take care of line endings), push it back to device (please take care of permissions+owner)
  • alternatively, rooting your device (not talking about ADB here :wink: ) may enable direct editing of the xml file from the device (not sure of that anyway …), for example with You can also copy the file to /sdcard to edit it with a PC, then copy back to it’s place (please take care of line endings & permissions+owner)

NB : I don’t remember exactly how it works right now, maybe the xml file is not used directly, but as a template when resetting the APNs.

Sorry it’s a little messy, but I think you’ll figure the whole idea out. Please feel free to ask for details.

Thanks, I haven’t kept up with updates so I need to do a manual update to S. I will do that first and try some of the things you posted.

I did not get to try anything yet, as I only had time today to update to 1.11/S.

The old APN is still there (I was hoping it would get blown away upgrading to S), and it still can’t be deleted. When I open the old one, it can’t be edited either (greyed out). The correct one can be edited. The phone still reverts back to the old APN.

Would you mind posting a more detailed process using ADB?

I was able to get the more complete APN profile from my new carrier. For some reason it wasn’t listed anywhere in their support database but I was able to get it directly from their tech support. For example, the Port #, MNC, APN type/protocol were not set correctly or they were blank. I have no idea if this will help keep the APN from switching on it’s own. Part of me suspects the mismatched MNC of the old vs. new APN might have caused the problem.

I did notice that now when I open the old carrier’s APN (it’s still there) eveything in it is greyed out/un-editable. If this means that the old APN won’t be used, or switched to randomly, I can live with it. It still can’t be deleted completely though.

I am going to monitor it over the next few days and see if the phone still switches.


Hi @cornfarmer,
That’s very good news!
Please keep us updated, as I suspect that a manually-entered APN may have some kind a priority on system-provided.

You old APN can’t be deleted probably because it’s provided by system, so it’s read-only.
If your device won’t use it anymore, it’s OK and can be simply forgotten.
For example, as a french Sosh (an Orange low-cost subsidiary) customer I can see a bunch of useless Orange and associated APN, but they don’t bother me (see screenshot in previous post).

You may want to inform upstream Lineage with your new APN, so they could add it to their xml file.
This way your APN may become system in the future :smiley_cat:

1 Like

This topic was automatically closed after 60 days. New replies are no longer allowed.