Can't unlock the bootloader on Google Pixel (sailfish)

I recently obtained an unlocked refurbished Google Pixel (sailfish) phone. I would like to install /e/, but I’m getting stuck at one of the very first steps: unlocking the bootloader. When I go to Settings → System → Developer Options, I find that OEM unlocking is greyed out, and it says “Connect to the Internet or contact your operator”. I am connected to the Internet, and I did contact my carrier, but to no avail.

Does anyone have any ideas as to how I can unlock the bootloader?

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Is it a Verizon USA handset? If so the bootloader is unable to be unlocked unfortunately. Though I have seen on some international models where it is greyed out in settings (because it has previously been unlocked before) so if you go into fastboot and unlock bootloader and it will still unlock.

Hi @b3pio. I don’t know if it’s a Versizon USA handset, since I bought it refurbished. Do you know if there’s a way I can find out? FWIW I’m in Canada.

I did try fastboot flashing unlock and fastbook oem unlock-go, but both commands returned the following.

FAILED (remote: 'oem unlock is not allowed')
fastboot: error: Command failed

I also just came across this page for OEM unlocking Verizon Pixels, and from the comments it seems that people have had mixed results. Also my Pixel came upgraded to Android 10, which might complicate things.

Yeah I think all of the work arounds were patched. Haven’t heard of them working anymore… You could always try?

Thanks @b3pio. I don’t have much experience messing around with phones…do you think this procedure might risk bricking the device?

@deepee, did you try it, and if so, did it work? It is extremely difficult and frustrating trying to find any kind of phone for sale on ebay or craigslist that is supported by /e/, accepted by carriers, isn’t carrier locked, and doesn’t have an unlockable bootloader.

Well, I found something that may help anyone worried about this. I found a Pixel on ebay and got the IMEI from the seller. When I checked it at Verizon’s BYOD page, that page actually reported that the phone was a “Non-VZW” model (but that it would work on their network). I had checked a couple other phones before this one, and they had not said anything about being Verizon or not. I don’t know if any other models are out there with non-unlockable bootloaders, like maybe AT&T? But I think you have a chance if that page tells you it’s a non-VZ phone.

Two versions of the pixel (1st generation) are available:

G-2PW4100 (North America) - SMPH00000004
G-2PW4200 (International / Global) - SMPH00000003

Also, basically if the model number ends with 100 then it’s a USA/North American model. Please compare them also here: Google Pixel and Pixel XL Model Numbers […] Differences. Compare them also here: Google Pixel Differences

The Pixel Int./Global version can be used in Europe without handicaps. The US versions are usually blocked by the carriers.

That agrees with what I found as well. The problem is that within the US model, phones sold through Verizon had a non-unlockable bootloader, (unless the workaround mentioned above does work), and there is nothing different about the model number, and not even a Verizon logo on the back or anything that will tell you whether the phone came from Verizon. This is different than, say, Samsung model numbers where they are specific to various carriers.
I did buy the phone I mentioned above, and although the OEM unlock option was greyed-out at first, after I tested the phone with stock ROM and a sim card, it was no longer greyed-out. I got /e/ installed on it with only one minor glitch – the most recent build of TWRP, twrp-3.3.1-0-sailfish.img, caused errors and failed to wipe the phone. Following advice from elsewhere, I used build instead. This still indicated a couple errors trying to mount something - /volume maybe? But in the end it said “successful” and everything appears to be working.

I too had trouble with the grayed-out option for “OEM unlock” on a Pixel. What solved it for me, was post #1003 in this xda thread. I had to repeat steps 12/13 a total of 3 times and then the OEM unlock option became available! Everything worked after that.

Hi @argon3030. Thanks for the tip. Do you remember when you did this? I read somewhere that these types of holes were quickly closed by Google.


Hi, yes, I performed this just last week on a used Pixel, and got /e/ installed successfully. It will only work on Android 9 and below. Many of the used and refurb Pixels are running Android 9 still and were not upgraded to 10.

Thanks @argon3030. Unfortunately my refurbished Pixel came with Android 10. :frowning:

I bought a moto z2 and it won’t unlock boot loader either. A bit discouraging because I bought it based on the working devices list. There should be a column for exceptions ie, “Verizon phones may not work…” part of the learning curve