Cant unzip recovery file to get files for flashing partitions

You might try this advice, in post #7 This quote is about Payload-Windows-GO the method of my first reply to you.

There is a tool called Payload-Windows-GO. Basically you just hover over the payload file over the EXE file of the tool and it extracts it. No commands or terminal needed. It’s been there for ages.

There is secondly

which is supported by the thread I have just mentioned:

All my extracted folders are empty.

I now think and assume your title asks a much more simple different question, than I assumed by

extract recovery image to get dtbo.img and Vendor_boot.img?

My apologies.

Start again !

You are stuck at this point ?

First unzip the /e/OS Recovery file linked in the section marked Downloads for renoir . The following files would show up in the location where you unzipped the contents of the eRecovery zip file

This is not as easy as I thought. What is available is NOT an “eRecovery zip” but the latest file is recovery-e-1.14-s-20230819321663-dev-renoir.img.

This link describes GUI methods to open an .img file, but untested by me

Please let us know how you get on, there are others facing this issue which seems to me new to our documentation.

Im just trying to install first clean instalation of eOS.

I will try again at night. Thank You for help.

If you try clean installation you might not need the dtbo.img. I tried on a spare Moto G7 Plus from v1.14-s via sideload to T. I did install recovery when I bumped from q to s. Others also installed before the workaround was available. Aboht further implications I don’t know.

try these steps on windows, as you need.
Download the rom you want to flash, e os rom s zip file.
Unzip it with winrar, 7zip, windows itself. You will get a new folder with payload.bin file inside.
Dowload now this tool, last release
Unzip it as before, and will get a new folder.
Inside this folder there is the application, FastbootEnhance.exe, open it as administrator.
Open Payload Dumper tab, click on browse and search the rom folder extracted at the beginning, double click on payload.bin file.
Open then partitions tab.
You will find all the partitions inside.
Highlight what you need and click on Extract Image.
You did the job !

Month ago I found a simple tool (on Youtube) to unpack that recovery.img

I just had to drag that image on exe file.

It was not payload windows go because it doesnt work.

Ext4 UnpackerExt2explore and many others doesnt work too.

I wanted to find and show you that tool. Ive spend hours on searching but just cannot.

Im anoyed and tired but will continue.

1 Like

A similar method is shown, but without the drag an drop:

You notice how there are several methods to extract the bits you need

  • payload dumper from the main ROM .zip
  • extract from e-recovery img Edit, not possible, not yet published !
  • via fastboot enhance from as @LilBeth

Good luck.

1 Like

I suggested to use fastboot enhance tool cause it works on windows, as requested.
Cause it’ s lightweight and doesn’ t need an installation on the pc.
You just run it in its folder.
Moreover, unlike payload dumper, it doesn’ t need additional software, on windows, to run it; see python for payload dumper.
Fastboot enhance, according to me, is a useful tool, coming with some interesting features.
Finally, to unzip archives, rom and fastboot enhance files, you can easily use windows, as pointed.
Give it a chance, you will be pleased.

1 Like

Ok. Ive tryed all of those solutions.

  • extract from e-recovery.img
    It was impossible to mount recovery image or to simply unzip it using winzip, 7zip or windows tool.
    I was trying to do this on 3 different PCs.

  • payload dumper from the main ROM .zip
    That method works but it took me some time to manage it.

  • via fastboot enhance from as @LilBeth
    That was most inuitive and noob friendly method. :slight_smile: Thank You :slight_smile:

Still it’s not possible to unpack recovery.img file -windows says that the file is corupted or just cannot open.

So still I will try to find that method with super easy tool which I found on Youtube and match your documented instalation proces.

glad to know you tried and found fastboot enhance useful for your goals.
But, i m asking, where did you find/get recovery.img you reported as corrupted/unable to open ?

When you unpacked payload.bin via fastboot enhance, you clearly got some partitions.
The partition named boot.img is the recovery you will need to flash the rom, extract it.
The others partitions you need, dtbo.img and vendor_boot.img are the same available, just extract them as well.

Take a look please at this wiki, just as reference.
E os is lineage os based.
Steps explained here to install lineage os 20/t will also work for e os s, based on lineage os 19.1
You will observe, is basically written, that the recovery.img is the boot.img
You don’ t need more than this, no need to unpack other files.
The next e os build, 1.16, will be shipped soon, read mid October.
This new release should fix the missing builds, recoveries and additional files as well.
Now It’ s all in your hands.

I am not a Windows user, but I think that Windows method is described in words as:

There is a tool called Payload-Windows-GO. Basically you just hover over the payload file over the EXE file of the tool and it extracts it.

quoted from the XDA forums link in Post #8 but this is relevant to extraction from the main only.

I think we have to look at this as an inadequacy in documentation as I also was not able to extract the required bits by following my reading of the /e/ install page quoted in Post #10. First I check my download was not corrupted.

$ cat recovery-e-1.14-s-20230819321663-dev-renoir.img.sha256sum
860a1d85e05837447a2969dd5011941edcae45cb9c7cf8d71e296551128ccfcb  recovery-e-1.14-s-20230819321663-dev-renoir.img

$ sha256sum recovery-e-1.14-s-20230819321663-dev-renoir.img
860a1d85e05837447a2969dd5011941edcae45cb9c7cf8d71e296551128ccfcb  recovery-e-1.14-s-20230819321663-dev-renoir.img

$ sudo mount -o loop /home/test/test/recovery-e-1.14-s-20230819321663-dev-renoir.img /media/two
mount: /media/two: wrong fs type, bad option, bad superblock on /dev/loop0, missing codepage or helper program, or other error.

agree with you about renoir’ s documentation stuff you pointed.
As we can observe in this page the recovery always came as a single img file, not as described and expected, so a zip.
Additional partitions, dtbo and vendor_boot images, are missing.
Unpacking recoveries images won’ t produce missing files.
I think the only way to get them, as of now, is by unzipping rom’ s zip to get payload.bin and then use the mentioned methods to unpack it obtaining required partitions, as i suggested in my previous post.

1 Like

Hi, thanks for the confirmation, I created Documentation instructions to extract dtbo.img and vendor_boot.img from e-recovery.img – #7386

1 Like

I think there is some confusion of language going on here. We don’t want to be extracting anything from e-recovery.img; a file with that name is a complete recovery.img in itself.

eOS is intending to bundle the necessary .img files for booting recovery all together for downloading where the user can simply unzip them. Take a look for example at this download page for lemonade where for eOS-S the files are bundled together as “Recovery and boot img” (no .img).

The name of the bundle can be anything so long as it’s a zip.

For the time being users can extract the payload.bin from the OS download zip and extract the .img’s from that.


Indeed, I agree. The lemonade page demonstrates the intention well and I had not previously seen this provision of needed files, thanks.

I made an edit to the issue

The wording “First unzip the /e/OS Recovery file” does correctly apply when the files are published in the format used on this page. Perhaps users need to be aware to wait for the images to be published in the intended format.

1 Like

There is indeed confusion here…

I tried following @aibd 's instructions but running the payload thing gives an error, even when adjusting last argument to simply dtbo:
$ ./payload-dumper-go -partitions -o dtbo,vbmeta 2023/10/16 06:19:37 File does not exist: dtbo,vbmeta

Any guidance, please?
I’m following the install instructions for hotdog which is affected by this issue (that I can’t fully understand).


I worked this out whilst you were finding me the answer. Noch einmal, vielen Danke!

This is the slightly different answer that I worked out:
correct format:
./payload-dumper-go payload.bin -partitions dtbo,vbmeta

  • where dtbo and vbmeta are the names of the .img files you are trying to extract
  • nominating an output folder with -o name didn’t work for me
1 Like

In the wrong command payload.bin is missing, and the -o inbetween -partitions and dtbo,vbmeta breaks the -partitions parameter, letting payload-dumper-go either see dtbo,vbmeta as the file to work with (which doesn’t exist) or as the output folder specified after -o (which doesn’t exist) … I can’t test the specifics right now.

1 Like