Can't upgrade from eOSr, Motorola XT2113-3


I am trying to upgrade a Motorola 5G Ace from eOS e-1.8.1-r-20230206257804-dev-kiev to either eOS
e-1.17-s-20231112351092-dev-kiev or e-1.21-t-20240325389105-dev-kiev but it fails with this error;

C:\PT35>adb sideload
adb: sideload connection failed: no devices/emulators found
adb: trying pre-KitKat sideload method…
adb: pre-KitKat sideload connection failed: no devices/emulators found.

So in other words the ADB is not working for some rerason. Yet when I use the command “adb reboot botloader” it reboots the phone?

Curently I have the eOS recovery at: recovery-e-1.21-t-20240325389105-dev-kiev. any ideas?

Regain your privacy! Adopt /e/OS the deGoogled mobile OS and online servicesphone

can you post a photo of which menu you’re in the recovery while enabling adb sideload support device side?

Haven’t upgraded in long, if that’s a concern, you always run the risk of a userdata being incompatible with the destination version.

1 Like

If you try adb devices in Recovery mode and also in Active sideload mode, do you still get the same error, or different.

Also worth a try perhaps, in case this is an adb error.

adb kill-server

adb start-server

However the change
e-1.8.1-r-20230206257804-dev-kiev → e-1.17-s-20231112351092-dev-kiev

would be a downdate and might fail for that reason.

An upgrade from Android 11 (R), Format data would be most likely required; and possibly return to Stock ROM

1 Like

This phone was at stock Android 11 with the latest stock update. I installed eOS-r on a factory formatted phone.

I am trying to now move to eOS-t. I will try some of the suggestions above. I may not answer thread for a day or two. Taxes are due in my country in two days LOL. But I will get back to thread when time permits.

Thanks, JETS

So I managed to update this phone to eOSt/Android 13. It seems I was not following the instructions to a “T”.

My error was once I had finished the flashing the recovery image I was rebooting the phone with the side keys to the recovery mode. I was necessary to physically shut the phone off and start from the top again.

This step " 5) Manually reboot into recovery mode".

Regards, JETS