Command line is totaly wrong for easy installer

strong textstrong textgood day
my command line does not work.
Is there a person out there that can give me the right command line to install easy installer on my Linux device?
Snap not working, tried sudo… not working, tried software manager… not found but in the manual mentioned for downlodading it (marked as the easy way…LoL).
I have Cinnamon Mint
I am already very frustrated since everything is shown as easy but here I am since Lunch and nothing moves.
here are my commands… I think what I do wrong is “latest”
sudo apt install easy-installer --channel=latest/beta

sudo apt install snapd install easy-installer
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Package snapd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Package ‘snapd’ has no installation candidate
Unable to locate package install
Unable to locate package easy-installer

sudo apt install easy-installer --channel=latest/beta
E: Command line option --channel=latest/beta is not understood in combination with the other options

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Here are instructions how to install snap on Linux Mint:

Once you’ve done that, you can install the easy-installer like described on


SIR!!! God bless you

oh I forgot
I already have e/os on my phone (FP4). just tried to reinstall it. Doesn’t work.
My issue is that My T from Toyota doesn’t work on e/os so I try to reinstall it. guess I have to make a factory reset like @MRTN has requested.
If that App then doesnt work how can I go back to bad Android?

I guess that is it… I made a factory reset and I am on v1.13 and MyT from Toyota does not work. A pity since I ike the philosophy from /e/os
I simply can’t sell my car…

How to install the original Fairphone system is described here:

A word of caution: when manually installing the system, one has to make sure that the security patch level of the version to be installed is not older than the one already installed.
The version available on the Fairphone page is FP4.SP29.B.069 and that has patch level 5th of May, 2023
If /e/ on your FP4 has a newer patch level you should wait for Fairphone to release the next install package.


thank you for your hint, I think your warning is alright, but now Iget those messages from my Terminal

INFO: The procedure will start soon. Please wait…
INFO: The package type is “user-factory”
INFO: The build number is “xxx”
INFO: You are using a Linux distribution.
ERROR: The ‘fastboot’ tool is not available.
ERROR: Please install the tool using your package manager.
ERROR: Aborting now (press Enter to terminate).

I am in Fast boot mode and the Device State says unlocked

To install fastboot on Mint do

sudo apt update
sudo apt install android-tools-adb android-tools-fastboot

Taken from


Thank you very much
I am one step further, but now getting this error.
I don’t know why The critical partitions are not unlocked…

*** Fairphone 4 flashing script ***

INFO: The procedure will start soon. Please wait…
INFO: The package type is “user-factory”
INFO: The build number is “xxx”
INFO: You are using a Linux distribution.

INFO: Validating the integrity of the package.
This might take a while. Please wait…
INFO: Validation complete.
WARNING: Flashing this image wipes all user data and settings on the phone.
It will also remove the Google factory reset protection.
Are you sure you want to continue?
Type “Yes” (case sensitive) and press enter to continue: Yes
INFO: Looking for connected device(s)…
INFO: One Fairphone 4 in fastboot mode found (serial number: xxxxxxx).
ERROR: The critical partitions are not unlocked.
Please refer to our support articles for help.
ERROR: Aborting now (press Enter to terminate).

Pleas don’t give up on me…!!!
kind regards

Looks like step 7 is missing from the “Part 2: On your computer (Windows and macOS)” section of

Yes, it only says windows and macos in the heading, but in the text it also addresses linux.

1 Like

Thank you very much for helping me. I made it!!! because of you! Unfortunately I had to go back to Android. Just because of an App I need…
But will look out for /e/OS, maybe Toyota will work someday on /e/OS.
I don’t know what the reason is. Toyota or /e/OS
Thank you and have a nice Sunday…
be blessed

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.