Connection issue with mobile data

Hi guys :slight_smile:

I have e/OS on a Samsung Galaxy S7. Almost everything is working fine so far. Just two issues. One is:

When the phone is connected via WiFi, all internet connections seem to work. I can browse all websites with the browser and all apps are functioning. But when the phone is connected via mobile data, then many websites (not all) cannot be loaded and some (!) apps, which need internet connection, are not functioning.

I think I have tested all possible settings. I also have un-installed the Karma firewall and de-activated the advanced privacy feature in e/OS temporarily, but no success. I also checked the mobile data settings of my mobile network provider. Switching between 4G/3G/2G also doesn’t help.

I suspect that it could be an issue with IPv6. According to tests like ipv6-test.com the phone has no ipv6 connection.

Any ideas about this?

Thank you very, very much.
Marcel

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Just to be sure: you’re referring to “APN”- settings, right? And your phone’s settings/parameters match with those defined by your provider in all detail, correct?

i am having the exact same issue. i cant figure out exactly what it is.

G930W8 carrier unlocked. running latest e/os/ Q stable.

Im running with VPN setup for always on connection and block non vpn connections. If i am on wifi everything works fine. as soon as i go to mobile carrier everything stops working. no internet whatsoever even though in settings, system, about device it says i am connected to Verizon with mobile data and shows my phones number.

i noticed if i shut off the vpn and run the phone without always on connection and block vpn sometimes the phone works on mobile data.

i have also shut off the Advanced Privacy to not block anything but it does not seem to help.

if i hit ##info## on the resulting info page it says it cant ping dns.

i have no clue what the issue is. any help would be appreciated. i tested this and repliacted the exact same issue on a second G930W8.

That might be a mixture of issues imho

It is counter-intuitive but try undo this - from what I experience (= least with my phone) and from what I read (sorry, can’t say where exactly, if I find it I’ll add it here) there’s a bug with this setting in android’s vpn-interface.
[edit: in that I was mistaken but I confirm from experience that there´s issues with the implementation of that “block non vpn connections” -feature of the vpn interface. If I switch it on: no internet connection possible at all (maybe only in my phone model, don´t know … might still apply to others as well)]

What “vpn”?

Have you doublechecked APN settings and compared versus/ adopted your providers presets/recommendations? (Experience says automatic sync after change of settings from provider’s end does not always work reliably with custom roms)

Also when changing settings give your phone a moment to adapt and reconnect etc.

As indicated by @obacht (welcome to you both, @marcelefo, @sabotage_154) are you in a new install ?

If yes, many new users get an unexpected #apn ( is a link) issue. Please ensure you have full contact with your carrier before mixing wifi and mobile data issues.

1 Like

Yes it appears like you are correct. It is APN problem, specifically changing the APN from IPV4/IPV6 to IPV4 fixes this issue for me. it seems like the rom doesnt work correctly with ipv6 on this device. This is what i had to do to get it working.

Download app 4G LTE Switcher app from google play.
Install and open the app.
Pick the 3rd option that says “Hidden Settings”
Now in search box in Hidden Settings search for APN.
Click on first option called APNs - Settings APN Settings
You will be taken to apn settings screen of device. It will say “Access Point Name settings are not available for this user”
Disregard that and click on the + on the top right hand of the screen.
Add the following apn:

APN name : Verizon 2

APN: vzwinternet

MMSC: http://mms.vtext.com/servlets/mms

MMS port: 80

MCC: 311

MNC: 480

Apn protocol: iPv4

Apn roaming protocol: iPv4

APN type: default,supl

Hit the 3 dots at the top right corner and hit SAVE. it will appear as if nothing happended or this didnt work.
Go back into the APN menu and you will see your new APN you created. Click the circle to set Verizon 2 APN you just created and your phone should start picking up data. if it doesnt just turn airplane mode off/on or reboot phone and you should be good to go.

Please keep in mind that the device still will not work for making calls because that is run thru VOLTE by verizon. This rom does not support VOLTE on this device. So for calls you will need an app that runs over the internet, a VOIP app, but this fix alllows you to fix mobile data issue on this device. Hope this helps someone. The phone runs really well not. 100mbs down in some areas!

1 Like