Consensus on best way of installing banking applications?

Dear /e/ users!

I just got my GS290 and I’m thrilled with it. The only think I’m lacking to make it my daily driver is support for some dutch banking apps (ING, ABN, Rabobank or Triodos) (I’m willing to switch banks for it!!)

I tried requesting and com.triodos.bankingnl on the /e/ app-store, but it says these apps have already been requested. Is there any update on this? If not, how else can we install these apps?

I found I could download the Aurora app store. How do I verify the signature of the apps? Does aurora do that?

Ideally, I’d like to download the apk from google play store, verify the signature of the downloaded apk then just install it on my /e/ phone. Yet, I can’t find how to check the apk signature anywhere.

How are you guys using mobile banking with /e/?


/e/ App store does not contain banking apps. I use Aurora to download them, Aurora fetches the apps from the Google play store. Rabobank and ING work well on /e/.

1 Like

Can confirm, this worked like a charm. The ING app works well on /e/. :slight_smile:

I’m in Ireland and my banking app for AIB (downloaded from Aurora and the subsequent APK checked on the website refused to work until I turned on the ‘safety net’ option in MicroG.

I have no Google account logged into MicroG and the AIB app works perfectly now.

As for the safety element, well I’ve had no issues or unusual activity on my account to date.

1 Like

I also used the ING app (The Dutch ING Bankieren). Works perfectly well, including push messages and contactless pay.
But now the App states that it needs an update, but the Aurora store gives an error message “You need to purchase this app first”. Anyone had the same experience and know how to fix that?

Mine still works but I downloaded just last week. Edit: just installed the latest update and it worked well. Sorry I can’t be of more help…

Did you install the update from the Aurora store? (the May 4 2021 version)
Edit: I updated the Aurora store from the /e/store, and now it works fine again!

1 Like