Corrupted Fairphone 4

I installed /e/ os on a Fairphone 4 using the easy installer. It was successful and the phone seemed to work perfectly fine. But I seem to have missed to lock the bootloader again during the process.

I veryfied the security patch level of the former OS and the new one. Same date, so it should be fine.
Then I locked my bootloader using adb and usb debugging. (stupid me… should have asked for advice first / researched better)

Then I got the message that the phone is corrupted. I unlocked it againg, which worked… but I can not boot the phone anymore, nor enter in recovery mode. But I can still enter into fastboot mode.

I guess that’s it, my phone is unusable and there is nothing that can be done? (even with the help from a professional) ?
I guess the inital mistake during the installation process was to boot without locking the bootloader? Or what might I have done wrong?

If you can get into fastboot and unlock works, manual installation should work: https://doc.e.foundation/devices/FP4/install Phone will be empty though…

2 Likes

Thank you so much! :slight_smile: Those are extremely good news!
As I never did this befoere… Might I try the easy installer again? Or do you think this will be too risky?

The easy installer will not do harm, you can try. When fastboot still works, there is hope :wink:

2 Likes

Ok, thank you! I tried but I already get stuck at the very beginning because the easy installer can not find the phone… But I have access through adb so I’ll go for the adventure of manually installing the OS :slight_smile:

1 Like

Time for easy recovery :wink:

Yes I agree! :joy: I would be a great fan

An other question… could I try and lock the boot loader again after the process? Could that work this time?
Is there a possibility that I could make things even worse if I do it?

Yes, should work, you can always unlock, but will erase userdata if you do.

2 Likes

I just installed the /e/ os manually with success! I locked the bootloader at the end and it actually worked!! :slight_smile: Thank you so much for your support. :smiley:

2 Likes