Crashing Bluetooth with 1.9-s-20230310268290-stable-FP4


I’ve never encountered any trouble with the Bluetooth with past releases. Since the update (I was running something like 1.5) tonight, impossible to use it anymore. Any clue? What shall I do to document the problem? Is it possible to return back to a past release? The list of available releases was cleaned after the installation of the latest one.


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

No issue on mine (1.9 stable as well).

Did you try to turn it off, remove the battery for 5 min, then boot it again?

I tried to power it off before posting but without success. After your message, I powered it off again and remove the battery for a few minutes. No result. When starting Bluetooth, after a few seconds I get: “Bluetooth s’arrete systematiquement, Infos sur l’appli ou Fermer l’application”. That can be translated to “Bluetooth turns off automatically, Info about the app or Close the app”.

No, due to the newer security patch just installed and the anti-rollback feature.

Also for me, no problem with Bluetooth, but I can’t suggest you a workaround.

If no one else replay here, you can look at Gitlab or open a ticket there.

@manoj: is this post to be moved in the “1.9…”?

Your error message reminds me of a fix – but I never before tried it on Bluetooth. Please try

Settings > Apps and notifications > See all … apps > 3 dot menu top right > Show system > Bluetooth > Storage & cache > Clear storage | Clear cache

Clear cache alone would be the minimum intervention, but may have no effect.
Clear storage will remove all Bluetooth pairings and you will be forced to a completely “fresh start” with the app.

1 Like

Great!! It looks like working or at least I don’t have the mesage again and Bluetooth has been switched on for more than 5 minutes… I’ll test tomorrow with an external device. Thanks for your advice.

I confirm that all is fine after cleaning the memory for Bluetooth application. Thanks again for your help.

Hi, same bluetooth issue as @cramik for my FP4 (same build). cleaning cache and storage solved it too. Thanks !

The fix worked also for me - many thanks!