[Custom Build] eOS Q for Samsung S9+ star2lte -- new build Sept. 16th

I have build a Q-eOS rom for S9 + with the alpha sources from eOS.

The build is untested. So use on own risk.

It is really a custom build, because I have made some changes in bootanimation, background, launcher and I have removed all goolag calls which are still in the alpha sources

September 16th: new build with resent button fix


Thank you

Has anyone on he forum tried this and can confirm if any additional steps are required vs just flashing it on top of existing pie build?

@SuzieQ could you answer the question from him ??

Well, there are usually always several ways to flash a ROM. It also depends on the user’s risk appetite.

A ‘dirty flash’ keeps a lot of data from the previous ROM. But if the ROMs are not compatible with each other, problems are inevitable.

A ‘clean flash’ wipes all the data away and paves the way for a more carefree user of the new ROM.

My recommendation: ‘Clean Flash’.

1 Like

Thanks, that I’m also prefer when flashing a new/different version.

thanks. I get an error stating I need a vendor Image for Android 10 for my device.
Can you share where you got the vendor image from?

There are several ways to download a Stock Android 10. An easy way is to update the stockROM via Samsung OTA update directly on the S9+

hmm… tried downloading BL and Vendor.img linked in the LOS17.1 forum on xda but didn’t work either for LOS17.1 or eOS version. just kept stuck at boot logo.
reverting back to my nandroid backup.

will wait for the stock firmware download to complete and make another attempt over the weekend

sammobile.com ?
Ask me in PM for premium fast download access…(only September 2020)

Thanks @piero, for now used SamFirm to download the latest firmware directly from samsung servers

1 Like

Do you have tried to flash vbmeta.img? ?

no, is that a vendor image file? where can i download that

EDIT: just googled it, and from XdA thread on it not sure if it needs to be specific to device / ROM version

EDIT 2: I am currently on eOS on Android 8 for star2lte

Most devices which where delivered with Androud 8.1 and Android 9 does have this vbmeta partition.
You have to flash it with
fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img

1 Like

fastboot on a Samsung Device ??

Yeah, right.but I don’t know how to flash it, incl. command with odin or heimdall

I flashed Samsung Stock Android 10, followed by flashing TWRP then

  • tried this Q image for eOS but get an error 'Failed to map file ’
  • Tried flashing LOS 17.1 -> works
  • retried installing eOS Q ROM with the same error 'Failed to map file ’

apparently samsung phones dont require a vbmeta?

UPDATE: attempted with TWRP 3.4 and 3.3.1

Could be, not every device have it.

Sorry, don’t know why the eOS-Q rom isn’t booting on your device. It is working on some other peoples devices

my bad, in the end turned out to be a bad download. :dizzy_face:
redownloaded the file again and it flashes fine.

puh … glad to here that. Hope you will enjoy my ‘LeOS’

1 Like

@SuzieQ I am assuming you are running this build on a S9+?
is the recent app button working for you? it appears to be a known issue with Android 10, although again, working for me on LOS 17.1

in my case the gesture navigation options are not available.