[CUSTOM MINI ME BUILDS] Galaxy S 4 Mini series for /e/OS-R

Galaxy S 4 Mini for /e/OS-R-1.16
Minimal build to be able to successfully build. Untested!

e-1.16-r-20231104-UNOFFICIAL-serrano3gxx.zip
https://www.androidfilehost.com/?fid=16385555061192796971

e-1.16-r-20231104-UNOFFICIAL-serranodsdd.zip
https://www.androidfilehost.com/?fid=16385555061192796972

e-1.16-r-20231104-UNOFFICIAL-serranoltexx.zip
https://www.androidfilehost.com/?fid=16385555061192796975

Please see sources and install instructions including recovery here:
https://xdaforums.com/t/rom-i9190-i9192-i9195-l520-r890-unofficial-11-0-0-lineageos-18-1-for-s4-mini.4189967/

Use it at your own risk!
Please support the developer(s)!

1 Like

thank you Ronald, i was trying to build that since 2 months, encountring multiples and various errors.

just installed, it boot, i will test major feature for me and repport…

Edit : first constatations

duplicate contact icon in bottom bar.

  1. Pdf Viewer is missing as it is reputed unsafe, it don’t hurt me
  2. Maps (Magic-Earth) is missing as expected, but can be added from AuroraStore or AppLounge
  3. Browser is missing as i dread, even it is reputed unsafe and can be replaced by another, the choice is difficult to make for average users
  4. Advanced-Privacy is missing as i dread, but cannot be installed as the app is not released as standalone app (it is not referenced in any store, only can be installed along /e/OS)
  5. SMS is missing too…

.

CONCLUSION :

in my opinion, this build cannot be called “UNOFFICIAL” !

and must be renamed “CUSTOM_MINI” or “CUSTOM_SLIM”

.

also…

this sources and install instructions including recovery and download links are not for serrano…
But for serranoVE witch is different device.

For serrano
https://xdaforums.com/t/rom-i9190-i9192-i9195-l520-r890-unofficial-11-0-0-lineageos-18-1-for-s4-mini.4189967/
is more accurate

2 Likes

Custom mini sounds good for S4 mini :slight_smile: Or Mini Me as small version of S4 :rofl:
I might try to include Advanced-Privacy, but do need to take out other package (that can be installed by AppLounge…)
btw. messenger app can be downloaded too via App Store (like QKSMS)

The main issue for this build is the ROM storage that is exceeded by current standard R /e/OS build and a minimal build with option export MINIMAL_APPS is not sufficient too.

You need to configure vendor/lineage/config/common.mk file and take out all packages that are optional and can be replaced later by downloading via Apps store.

2 Likes

I tried again and could not build with AdvancedPrivacy included.

However, you can download the /e/OS apps here:
https://gitlab.e.foundation/e/os/android_prebuilts_prebuiltapks_lfs

If you want to do this in the future you have to try to take out what is not mandatory as apps and themes in vendor/lineage/config/common.mk

1 Like

e-1.17-r-20231106-CUSTOM_MINI-serranoltexx.zip

@piero

Thank you very much! You really have accomplished great things!

Just, as I’ve had this with LineageOS an other earlier /e ROMS on thre devices the Samsung boo-image states ‘GT-I9195’ but TWRP and some parts of Android see it as ‘GT-I9190 (serrano3gxx)’.
Have you observed this somewhere, too?

|

| | Screenshot_20231109-113418_OwnerSettings|

So with the TWRP on the phone I could not flash your ROM, due to the missmatch device names.
I then flashed your recovery, right in TWRP, booted into recovery and die the update from SD-Card (named PODCASTS)

It did boot pretty fast, camera, account, sync, wifi — the whole shebang is working!

AWESOME mate
:smiley:

no (i have istalled it from TWRP)
.
i see your I9195XXUBML4 is a very old firmware
(Jelly Bean 4.2.2 not matching the build target KitKat 4.4.2 → I9195XXUCQL2)

By now I have two oft those:
|

||

Which are infact ‘GT-I9190 (serrano3gxx)’ and I’m happy I can flash them with the /e recovery, as I simply use them on WiFi, without any sim.

With a sim card, the only issue is, the dialer app crashes.

You mean a i9190 with motherboard labeled as i9195 ?

.

Have you tried to fisrt update your “I9195XXUBML4” firmware (or replace it) to a “I9195XXxCxxx” before install the “custom/e/”
The mismatch could be the cause of the issue…

I recall that was a problem in earlier versions (pre 1.0) of /e/OS. The solution yhrn was to use a different dialer r.h. Simple Dialer from F-Droid

https://f-droid.org/packages/com.simplemobiletools.dialer/

The label in the battery compartment, as well as Samsung boot logo…
So far I never had labels, with wrong Samsung model names.
I had flashed TWRP on them a long time ago, booted into TWRP to install your ROM and then had the mismatch.

How many others react as espected ?

I will try with a SIM card in my test device when i will have time. But in -->settings -->about the phone, it is noticed i9195

No, not that simple :wink:

Text messages, configuration of the mobile network… crash, too.
The ROM was not meant for this hardware… and/or the old firmware.

Well, just tried #5 , they all mismatch.

They just some how are ‘GT-I9190 (serrano3gxx)’ – 3g only and no 4g LTE

Great spotting, @piero
Today, I finally got the very last available, put it on all 5 devices, went through set up once, put a sim in, made a call, flashed TWRP and finally your build.
All problems are gone, made calls, set up sync, got my notes, camera works…

As I know, how hard you worked for this build, I put a little tank you note in my profile :pray:
(only got three batteries, unfortunately)

1 Like