Default file manager (files app) how to delete

Hello fellow e os users

I have tried for a while to find information on this app. I can’t seem to be able to delete files. Seems starnge to have a file manager without the option to delete.

If i select a file or a number of files, then a notification appears with the “selected”

If i click on the 3 dots (hard to see with my theme) in the top right side i only get the following options

Open with
Sort by…
Select all
Copy to…
Move to… (greyed out)
Compress (greyed out)
Rename (greyed out)
Get Info

Does anyone know how i can delete old files?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Think you must tap on a file an hold the tap until a context menu opens. This context menu contains a Delete.

thaks for getting back to me.

must be a bug then, because that doesn’t do anything

Ahm … this does indeed not do anything, interesting. Probably one of these indispensable GUI improvements …

I suggest to use TotalCommander or similar for general file management. This gives you much more functionality, especially two panes very handy for copying or moving files.

1 Like

That looks like an issue. In the screenshot there should be a share icon and a delete dustbin icon next to the three invisible dots! :wink:

I notice the same omission on LineageOS 18.1 as well.

As a workaround go to the corresponding location of the documents on the phone’s storage; you can delete from there.To do that: pull out the menu from the left side of the screen, or select from the hamburger menu at top left of screen and tap on your phone icon at the bottom of the list.

Actually, the problem seems to be just with the Recents selection. Select from Images or Audio on the pull out menu and the dustbin/trash icon is present. Is it the same for you?


Raised a bug report

It’s also not present in the stock Android (FP3) files app when looking at the recent files. So at least it’s consistent :wink:

Yes the dust bin / trash icon appears if i go to downloads or a folder from the side menu. Thanks

March 2023 (I’m new to e/OS), this bug still not resolved. Actually the only reasons for me to use file managers on my phone is to delete, move, or preview files. Failing 2/3 of these is pretty dismal!

I found this app which is essentially identical to the pre-installed app, but with the missing functionality returned. From the description, it sounds like this little 81kB app is just a script to call some pre-existing file manager fundamental to Android operating systems in general.

Hope that helps

I do not believe that not being able to delete files from the Recent is a bug as that is the behavior across all of my ROMs going back to Oreo at least. As well as not being able to Move, Compress, nor Rename (shown grayed out on older Android).

Probably by design as Recent is just a quick way to access newly added/modified files. As mentioned one can do their file management from pretty much any other area/section.