Default Mail App not showing latest emails in common Inbox

Hello,

Since last update, the very good mail app 5fork of K9) is not showing incoming emails in the main inbox common to all the email accounts registered in the app.
When I receive a new email, it is showing in the inbox of the specific email account. After opening this inbox folder, the new email then show up in the main common inbox.

Is anybody facing this new behaviour ?
I am still hesitating to clear app data or un-register my accounts as it may not solve the solution and I am afraid the settings backup will not save everything.

Thanks

Hello,

What gives a swipe down from the “All inboxes” screen?

It forces the loading of new emails in all email accounts as before thoug the new email do not show-up in the common folder, they only show up first in the sub-folders specific of each email account (showing a “1” for unread message only in those sub folders).
The new email appears in the common folder only after going inside the specific sub-folder with the new email.

If you don’t want to reset app configuration you can export it’s conf (it’s pure XML), maybe the problem will show inside. XML file should import by the same way.

Then open file with a text/XML editor and search for folders lists, in my export only Inbox have “integrate” to “true”.

I have erased all the app data and restored the parameters and email config export though the problem is still present. Fortunately, the restoration has worked flawlessly.

Did you try this with your config backup file?

Hello,
Yes I checked and unfortunately the configuration is correct (it has not changed compared to the previos situation where there was no problem)


<folders>
        <folder name="INBOX">
          <value key="integrate">true</value>
          <value key="inTopGroup">false</value>
          <value key="syncMode">FIRST_CLASS</value>
          <value key="displayMode">FIRST_CLASS</value>
          <value key="notifyMode">FIRST_CLASS</value>
          <value key="pushMode">FIRST_CLASS</value>
        </folder>
        <folder name="DRAFT">
          <value key="integrate">false</value>

You may try to uncheck “Unified” for all Inbox folders, then check them back one by one.
More info here: https://forum.k9mail.app/t/unified-inbox-not-working/6119.

1 Like

Hello, thanks for finding that post.
I have tried that however the problem is still present.

I have also installed the K9 app on another phone, and again the problem is still present.
As I tinkered with the config file and Unified/integrate settings without success, it looks like it may be a bug of the last app update.

I think it maybe related to one of your accounts: many others (me included) doesn’t have this problem.
Does one account have funny chars (accents for example), or is more than 64 chars long?

Hello,
No account is using non-ASKII characters and the length of them is shorter than 30chars.
It might be linked to my configu, though the problem did appear since last update.

Hi,

What’s the Mail app version associated to 1.18?
Has it been updated to a more recent version than 6.710?

Sorry, out of ideas here :frowning_face:
There is for sure a bug, but I can’t figure out what triggered it in your case …

Hi,

You may find some answers here: https://gitlab.e.foundation/e/os/mail/-/merge_requests/153

2 Likes

Thank you for your help. I guess I will simply wait for the app to update.

I updated to 1.18-s stable on my FP4 and I can not reproduce your bug.