Disabling notifications for Mail application


I have an issue with the notification settings for the Mail application.
Unlike other apps, the “show notifications” toggle is greyed and I cannot change the setting. Today, I have to activate “do not disturb” mode in order to disable those notifications, which obviously blocks way more than I would like to.

I used to be able to disable them in previous versions of e/OS, but it appears that in e/OS 1.1-20220627199797 it is not possible anymore.

Is this intentional ?
Any work around available ?
Or maybe I missed something ?

Thanks for your help,
Regain your privacy! Adopt /e/ the unGoogled mobile OS and online services![phone|80x80]

Hi Flavien, No idea whether this is intentional but it’s the same on a couple of devices I have so I don’t think you are missing anything.

Workaround is to disable notifications in the Mail app settings >Accounts > tap your account name > notifications > uncheck New mail Notifications (tip: leave this screen running so you can get back quickly when you want to turn them on again)

1 Like