Display on phone broken, need help accessing files on the device [/e/OS v1.5]

TL;DR I need screenshots from an /e/OS 1.5 user to show the steps for allowing file access over a USB connection


I was running /e/OS 1.5 on a Fairphone 3, but after some water damage the display is absolutely dead. The phone still works, however, and I really need to get some files off of the device.

I have a USB hub and mouse so I can interact with the device, but I’m doing so blind (as I’m not able to get any HDMI output from the phone). I now have a new phone (Samsung Galaxy A13) that isn’t compatible with /e/OS, so I don’t have an exact replica of the /e/OS 1.5 layout to work out mouse movements on.

I have connected my Fairphone to my Galaxy via the hub, but the Fairphone defaults into charging-only mode when connected to another device. I need to get to the setting to change that so that I can access the files on the device from my new phone.

My Ask

So, I need somebody with a device running /e/OS v1.5 to:

  1. connect their device to another phone or a computer via USB
  2. screenshot every step needed to access the USB connection settings screen (i.e., slide from top of screen, click USB notification to open it, click opened notification to access settings menu, layout of settings menu)
  3. share those screenshots here

I would really appreciate if anybody would be able to help with this.


Of course, if anybody could tell me an easier way of accessing the files on my Fairphone that would also be greatly appreciated.

Currently, when I connect the device to my laptop (running Ubuntu) the FP3 shows up in the list of removable drives, but when I click on it to mount it it waits a while before timing out with an error about being ‘unable to open MTP device’.

I don’t recall if that indicates that I’ve managed to change the USB access mode already and can access the device by installing something on my laptop, or if that is just what happens when the phone is set to ‘charge only’ mode.

What Android version do you run (R/11 or S/12) ?
If it is a “dev” release, did you enable Developer Mode and authorize any computer ?

1 Like

Not sure this helps … but I have scrcpy installed on my Ruin’dows 10 PC, and after connecting the phone to the PC with phone USB cable (USC-C - USB-A), and starting scrpy on the PC, I instantly get a window with a copy the phone screen, where I can click with the mouse as if I was taping on, the phone screen, and with the expected effect on the phone …
(don’t remember though if I had first to configure something on the phone to have it work that straight)

I’m not an /e/ dev, so I assume I was using a production release (specifically v1.5-20221028230215 if that helps). I think I had developer mode + USB debugging enabled though.

Just fyi, if you’re considering replacing the screen, Fairphone is currently offering a 10% discount, so a display unit is about €90 with shipping in Europe. Maybe you could get about that much for a used, working FP3?

Another alternative might just be if you can find a Fairphone Angel in your area and ask very nicely for help with borrowing (renting) a display so you can access your files.

Unfortunately I’m in Central America until next summer; Fairphones are only repairable within Europe.

you wouldn’t ask to use mtp if adb would work - because then you could just adb pull all files or install scrcpy via adb. Me suggesting enabling mtp via adb wouldn’t make sense but I’ll do it anyway - android - Enable MTP using ADB - Stack Overflow

If adb is enabled, accepting the device key is maybe necessary, but there’s a good chance you can hit it blind.

I can create you a video to navigate. But where is your “Settings” symbol in the 4x6 (h x v) grid to get it all started? name your number if abcd is h(orizontal), 123456 v(ertical)

My FP3 is already on S - will probably use a device on R as settings are already different.

me@laptop:~$ adb shell svc usb setFunctions mtp true
error: no devices/emulators found

adb doesn’t recognise that the device is connected:

me@laptop:~$ adb devices
List of devices attached

I don’t follow re: the Settings symbol — I shouldn’t need to go into the Settings menu should I, if a link to the specific setting I need (USB Mode) appears in a notification upon USB connection?

As the error message appears to have identified an MPT device, I think it would be worth being at least checking out your Ubuntu environment if you had not previously used your Ubuntu file manager to browse the device.

I am able to view the internal storage of Android devices with Thurnar if USB Preferences on the device are set to allow data transfer.

The mtp issue seemed a bit different for me between Debian 10 and 11, but I speculate that it was the default settings of the file manager which was responsible. However when in Debian 10 I installed gvfs-fuse and dependencies and recommendations.

I do not know Ubuntu, so your mileage may vary and might depend on Ubuntu version and file manager. When I search your error + Ubuntu I see that gmtp is suggested.

On a light-weight Debian 11 without Gnome when I run

# apt-cache search gvfs

I find all of these and more gvfs gvfs-backends gvfs-fuse

You might try

# apt-get install gvfs gvfs-backends gvfs-fuse

… and / or

# apt-get install gmtp

… just to see if anything changes.

For ADB access to the phone “USB debugging” or “Android debugging” (name depends on OS and its version) needs to be enabled in the Developer options (after they were made visible by tapping the Build number a few times) in the Settings.
And even with this, Android will first prompt you for granting this access to the computer you try it from (with a switch to remember this decision for the respective computer in the future).

The USB connection mode you get a notification for upon connecting the phone doesn’t help with ADB.

gmtp was the only newly-installed package, but it didn’t work:

me@laptop:~$ gmtp
Device 0 (VID=18d1 and PID=4ee1) is a Google Inc Nexus/Pixel (MTP).
PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
LIBMTP libusb: Attempt to reset device
LIBMTP PANIC: failed to open session on second attempt
Detect: Unable to open raw device?
LIBMTP PANIC: Trying to dump the error stack of a NULL device!
LIBMTP PANIC: Trying to clear the error stack of a NULL device!

gmtp is merely to support your file manager. Is an error shown when you attempt to browse your device, having started your file manager from a terminal ?

… is your file manager capable of browsing your other Android device ?

Ah, thanks for the explanation. I am pretty sure I had USB Debugging enabled on the Fairphone, but I’ve never connected to it via ADB before.

If I connect my Galaxy A13 to my laptop now, then the prompt ‘Allow access to phone data?’ appears at the bottom of the phone display and the device appears for ADB (before I’ve made a selection on the prompt):

me@laptop:~$ adb devices
List of devices attached
RF8TA08EZRM	device

But as I said, when I connect my Fairphone to the laptop there is nothing shown when I run adb devices (but the phone LED comes on and the device appears as a removable drive in the File Browser):


And it appears after running lsusb, as an MTP device (although misidentified as a Google Nexus/Pixel):

me@laptop:~$ lsusb
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 0bda:0316 Realtek Semiconductor Corp. Card Reader
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 5986:2113 Acer, Inc SunplusIT Integrated Camera
Bus 001 Device 013: ID 18d1:4ee1 Google Inc. Nexus/Pixel Device (MTP)
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I’ve just tested something with my Galaxy: I restarted the device and then connected it to my laptop before entering my PIN. It appeared as a removable drive, and when I clicked on it I got the same timeout and MTP error, which tells me that my Fairphone is still in the immediate post-boot state (i.e., I haven’t entered my PIN, so the disk has not been decrypted yet). However, I’m not sure why it isn’t showing up for adb devices, as the Galaxy does even before I first enter my PIN.

After entering my PIN on my Galaxy, I am able to mount the phone on my laptop but it shows it as empty until I press ‘Allow’ on the access popup.

So I think that firstly, I need to get to at least that state with my Fairphone (i.e., able to mount it, but with the drive showing as empty) to prove that I can interact with the device enough to enter my PIN to complete the boot process. I’m not sure what to make of the fact that the Galaxy shows up for adb devices and the Fairphone doesn’t though, since I’m not familiar with ADB prior to this.

To that end:

If anyone is currently using /e/OS 1.5, would you be able to post a screenshot of the default power menu (i.e., the menu of icons that appears along the top of the screen when you hold the power button down for a second)? If I hold down the power button on my Fairphone I get the small vibration that tells me that that menu is being displayed, and IIRC I need to click the middle button (of the 3) to show the Shut Down and Restart buttons, and then I can click one of those, but it doesn’t seem to be working. If I can make the phone shut down/restart, then I know that I definitely do have mouse interaction, so I want to rule out the possibility that I just forgot what the menu layout is like first.

No error message shown in Terminal when I open Nautilus from it, just this pop-up after the timeout (with the second number increasing each time):

Screenshot from 2022-11-27 13-00-23

I am able to access my other Android device without a problem, as I’ve described here.