Doesn't switch from 2G to higher versions

Hello team,
I use one plus x. Recently I travelled for a week to smaller towns and I observed a behaviours which I thought should be respoerted as it seems like a bug. The places I visited mostly being smaller towns most of the times I was in H+ coverage. Depending up on the signal strength and other factos it kept switching between H+ and LTE. But whenever it switched to E(2G) the phone never switched back to any of the higher versions. This happened even when I went to the places where earlier I could get LTE or H+. So I decided to reboot the phone and my suspicion turned out to be true. Phone seamlessly started switching between H+ and LTE. This phenomenon I could observe multiple times.
Please look in to this issue.

For a work-around I guess you only have to enable flight mode and disable it again, so the connection is setup again… So at least you don’t have to reboot all the time…
maybe create an issue for this in the bugtracker:

Thanks. I shall try that option going forward. I don’t have a gitlab ID for now. I will have to create one to complete this.

I have also noticed some similar behavior. I have a 1 hour commute to work and have seen the data connection stop working though I haven’t been able to really investigate it, because I am driving :smile: I use Waze to monitor traffic so the app will sometimes display an “Establishing connection” message and I also have to turn cell data off/on or restart to get data back. Where I am driving I also experience connections to changing protocols, 1x, 3G, LTE.

This sounds like very old bug like I had on my Oneplus One running CM13.1! In my case if I lost mobile reception it wouldn’t come back without the flight mode toggle.

@Dravidian were you able to check if the flight mode enable\disable worked?

I couldn’t as I have already returned to city and I don’t experience the problem here. If I experience the problem again in future I will post the update for sure. Thanks for checking .

It worked . today I got an opportunity to test it.

Thanks for the update @Dravidian good to know that the fix worked