Downgrading to a previous build version?

Hi all,

I’ve recently upgraded from e-0.10-o-2020080766690-dev-pioneer to e-0.12-o-2020100176269-dev-pioneer (Xperia XA2), and this caused my device’s audio to malfunction : no microphone input nor speaker/jack output.

I have reported the issue and I am looking for a safe way to downgrade to a previous version without losing my personal data and installed apps. Do you think dirty flashing from recovery is a good idea ?

Thanks in advance :slight_smile:

1 Like

Hi @chrisrg, thanks for the reply.
It was an OTA update so I tried switching from slot b to slot a, but afterwards the current-slot variable held value _a instead of a, is this normal behavior ? After switching, my device gets stuck on the boot logo when booting so I’ve switched back to the b slot and it boots v 0.12 properly.

Also, how do you check the current slot from LOS Recovery ?

Similar question, but in my case I don’t need to keep data and apps. Is there any problem with re-flashing a device that had a newer version of /e/ on it? E.g. a Q version, going back to an older N version by manual flashing?

Probably not but there are some Samsung threads were stock Android doesn’t allow downgrading…

You got output from getvar current-slot as current slot:_a, is that correct? Not seen that before; would guess that’s not normal. I’m guessing you switched a rebooted to a all via fastboot. Maybe it just didn’t work properly and is still viable; but is it worth your time to investigate and have another go?

Back in Aug I did a clean install of pie testbuild 0.9 for pioneer. Bit later eOS asks people to do a clean install of pie test build 0.10 “improved version which would take ota’s”. I did this, but did not format data. Everything worked, I had my data and a few days later an ota arrived which again worked ok. So my dirty flashing didn’t seem to upset anything. I’ve been on the same build since then with no updates waiting patiently for something else to happen at e! :roll_eyes:

So maybe it is worth trying a dirty flash from slot b to end up with 0.11 on a, your call. I find it useful at all times on XA2 to manually reboot to recovery after sideloading the zip to check the slot and reboot system from there. Once or twice there has been a problem picked up by recovery and factory reset has been prompted, so it’s not without risk of losing data.

1 Like

I have the same problem with e-0.12-o-2020100176269-dev-pioneer (Xperia XA2). Did you figure something out?

@chrisrg Yes, I get current-slot: _a even after several trials.
Since LineageOS recommends a fresh install to downgrade, I wouldn’t try dirty flashing unless I hear from someone who did it successfully.

I don’t get the slot, android and build version in recovery like you do. Weird.

Hi @bergtinn ! No, I’m patiently waiting for a new update… and I’m considering a fresh installation.

@Verko I’m no expert but this is what I would do in your case…

Assume that the v0.12 ota has fluffed up slot b; so from this recovery dirty flash v0.10.

Reboot and v0.10 should now have installed over your last version on slot a. Check it out and see if all works as it did before. If you get offered ota’s don’t take any at this stage.

If everything on 0.10 looks ok, then from this slot’s recovery flash the lineage copy partitions zip as per their installation instructions. This should repair slot b.

Then dirty flash v0.11 , or apply it as an ota if you are offered one.

Then wait for v0.13, coming soon to a device near you!

Just upgraded to 13 and everything seems to be working now. Beautiful!