Downloaded apps that don't work

support
microg

#1

I was testing apps to find out whether they work properly. Basically everything what I tried out worked on /e/. Great! Just this morning I came across several apps from the public French radio that did not want to start on my /e/ system.

  • Radio FIP: com.radiofrance.radio.fip.android
  • France Inter: com.radiofrance.radio.franceinter.android
  • Fradio France: com.radiofrance.radio.radiofrance.android

Any clue what to do to get them running?


#2

Hi @ralxx have you been able to use these apps on LinegeOs4MicroG ROM’s. Just wanted to check if this was an issue related to MicorG. As you maybe aware some apps need Google play service to work. On /e/ we use MicroG which mimics googleplay while protecting user privacy. Some apps do not work correctly with MicroG. We are working to reduce / remove such issues with the MicroG implementation on /e/.


#3

Well, then take it just as a notification that there are some issues.
Interestingly, other appes from Radio France work without issues.


#4

No, i did not rest them on Lineage OS yet. Ill fo that next week


#5

thanks @ralxx do check and let us know. That will help us isolate if it is an issue with /e/ specifically.


#6

Hi @Manoj, sorry for my delay in replying. I just checked the three apps mentioned above with the latest lineage-15.1-20190320-microG. And the apps are not working on Lineage either. Hope that helps to isolating the issue a bit more - although it is rather on the Lineage side…


#7

Thanks for testing this out. This looks to be a MicroG issue. One of the projects open with us is to enable all apps to work with MicroG.


#8

@ralxx, I was curious about your issue and decided to do some testing.
All three failed for me also on /e/. Using MatLog I recorded the crashes. The main culprit being this…

Caused by: java.lang.NullPointerException: Attempt to invoke interface method ‘com.google.android.gms.cast.framework.zzp com.google.android.gms.cast.framework.zzj.zzac()’ on a null object reference

Doing some web cross reference I see that microG doesn’t quite gel with that Cast Framework requirement. There’s a big BUT here though. Decided to also try those apps on other devices with microG, five ROMs from KitKat to Oreo. The apps run fine on ROMs using the modified and regularly updated microG from nanolx/Setialpha (NanoDroid) on three ROMs. The apps fail with the official microG on two others.

Both are at v0.2.6 but the main difference is that the modded/patched microG attempts to stay in line with Google Play Services versioning. That helps with those annoying prompts about AppXYZ won’t run unless Play Services is updated. Granted, we’re not seeing that kind of behavior but I believe it’s an “age” thing. The official microG hasn’t been updated in awhile so it mimics a somewhat older version of GServices. Good news is that the main (only?) microG dev, mar-v-in, is active again. Hopefully we’ll see a new core that’ll make its way into /e/.

On a side note, that Fip app is pretty cool. Nice eclectic mix of music. Not sure why it’s twice the size of the other two and uses/needs camera permission though.