E-0.7-n-2019122535327-dev-athene.zip on XT1622 does not boot up

fails for me. I installed twrp-3.2.1-0-athene, unlocked the boot loader and can boot into the recovery mode. Installing the custom kernel, e.g. e-0.7-n-2019122535327-dev-athene.zip or any other custom kernel for athene via adb sideload worked without error or warning.
However rebooting just does not work. The phone switches off and stays off. The only way to get it back on is the recovery.
I did not find anything in the dmesg.log or recovery.log, but I am not sure, this is the place to look.

Any help is appreciated.

Kind regards

Hi, that’s bad :frowning:
first I have to clarify something: you are flashing a rom, not a kernel. The kernel is included in the rom.

Do you have wiped /system / davlik / cache /data ? Have you formatted /data before flashing the rom ?

Hi Harvey186, many thanks for your reply. I did never go deeply into the matter, so I am not very proficient in the matter. I might have screwed it up completely. But apart from not booting I don’t see anything giving a clue one way or the other. I thought the trwp is sort of a minimal system and needs only to replaced/appended with a full system.

I am not sure if I flash the complete ROM, probably not always. How can I tell the difference?

I wipe the system/davlik/cache always. I have formatted data once, but do not always.

Maybe a bit to history, I installed twrp and unlocked the bootloader, this worked and booted into the Motorola Nougat distribution. The problem started after installing UPDATE-SuperSU-v2.82-20170528234214.zip. After this, it did not boot again. Then I started looking around for solution and did a few things, but to no avail.

I also tried to reinstall the firmware (???, name XT1622_ATHENE_6.0.1_MPJ24.139-23.4_cid50_subsidy-DEFAULT_CFC.xml.zip), but this did not work properly, probably because it was a downgrading (at least that was the error message).


Well, that doesn’t sound too good. :frowning:
At first some technical:

  1. TWP is a custom recovery. Like the name says, it’s for recovery flashing a om is a one way for “recovery” :wink:
  2. Firmware is the name for the rom which comes from he manufacturer

OK, now to your problem:
why do you have tried to flash SuperSu ?? Excuse me, but do you know what rooting is and for what it is needed ? I just have had a discussion about rooting a phone and which risk it is.

I would prefer to start over again with flashstock.bat like described here

If this will work, go this way

  • Reboot into TWRP
  • Now ONLY tick Dalvik Cache , System , Data and Cache
  • After ticking those, Swipe below to wipe
  • Once the wipe has completed return to home and select the eOS.zip
  • After you selected the zip swipe below to install it
  • When all of this is done, reboot into system

And if you really, really, really need root, flash magisk from XDA wen site. But better you will work without rooting :wink:

Thanks for the discussion, I wanted to root the device first to chuck out some of the more obnoxious apps. I use linux as a working environment and am a little aware of the dangers which come with using root. But that’s about is it, I admit.

I also had the impression, that I need superuser to be able to install a new kernel, probably wrong, I did no do proper research… . Probably the danger if one knows a little, one tends to jump to conclusions, atr least II do.

Anyway, I tried to flash the custom rom and it worked, although I had already given up, you made my day!

Many thanks and have a great New Years Eve

Thx and good to hear. Enjoy eOS and happy new years eve