E-1.8.1-q OnePlus 5T dumpling no more fastboot

OnePlus 5010 5T
Android 10
/e/os 1.8.120230206257879-dumpling

Hello, I have been a reader here in the forum for years, was able to learn a lot and apply it myself. On my Oneplus 5010 5T I have already tried some roms and now stuck with the /e/os.

However, I can use adb normally, but my oneplus is no longer recognized by fastboot. Also, the sideload via the recovery no longer works. I have tried several ports and a different cable, PC restarted, mobile phone also, also reset, unfortunately nothing to do.
Does anyone have any advice?

Hi @nackles44 welcome to the /e/ forum.

I may have misunderstood at first reading what you meant by stuck ! Can we just work through the basics ?

so the phone is apparently working ok … with e-1.8.1-q-20230206257879-dev-dumpling

adb devices – gets a response,

With the device powered off - hold Volume Up + Power. does the phone correctly enter fastboot mode ?

fastboot devices – gets no response ?

What changed since fastboot devices was working last ?

Thank you in advance for the help. So by getting stuck - that was a translation error - I meant that I stayed with /e/os.

Yes, by pressing the buttons, the device boots correctly into fastboot mode but the input FastBoot Devices does not show a connected device.
When I try to flash an image in fastboot mode, I get the info < waiting for device >

I don’t know if Fastboot worked before. I haven’t needed Fastboot mode since the E OS installation.

Is there a setting in the developer options that I need to activate?
As written, I have already flashed umpteen custom roms on the device, very strange that it is no longer recognized.

You need to have allowed / enabled USB debugging https://doc.e.foundation/pages/enable-usb-debugging.html (perhaps it got disabled with an earlier factory reset ?)

The above can be responsible for this … if not perhaps review

  • Android Debug Bridge following the links within to check the adb install on your PC, if necessary.