E-cloud sync fails with socket timeout exception even though address is reachable otherwise

There seems to be a connectivity issue which causes e-cloud sync to fail on a GS290 running /e/ v0.23-q (same for versions since at least v0.19-q before).

Synchronizing contacts and notes between the device and e-cloud keeps failing, occasionally with a toast message such as this popping up:

java.net.SocketTimeoutException: failed to
connect to ecloud.global/
(port 443) from / (port
39244) after 10000ms

The issue persists no matter which network is used (home WiFi or mobile). Also visiting https://ecloud.global using the web browser on that same device works without problems.

Solutions that worked for others in the /e/ community have not worked to fix the issue in this case:

The ecloud profiles were removed and re-registered in the account settings, to no effect. Same after several OTA updates.

The “Data saver” setting in SettingsData usage is disabled.

Any ideas what could be the cause or what could be tried to diagnose / fix this?

This topic was automatically closed after 30 days. New replies are no longer allowed.