/e/ First Use Dialog, after setting the time, Empty "Settings" app appears. Reboot same

Hello together,
i managed to install /e/ on my Sony z3 compact. I use the unofficial build from here:

Everything went fine, but after setting the time in the first use app, nothings happens, system stucks, sometimes the android info “Settings does not resport” Close/Wait, appers.

What to do to trubleshoot?


Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Hello, welcome in the forum :slight_smile:

Did you use the build made by Unknown or from petefoth ?

i user the latest from taht post, from petefoth

Ok, i was able to create a new user on the phone and to switch to that user, then i see the home screen, apps work so far, like radio/camera/etc but when i try to use the settingsapp, it stucks again. is there a way to debug this behavior, or to install a nother version of the settingsapp?


ok, it seems to have something to do with wifi, from the shortlist, (swipe from above) i can switch on/off BT, Flashlight etc, but wifi changes the icon, but falls bach to off in a few seconds. any sugestion?

ok same error with stuck on settings app in nightly lineage os version…

When the setting app is crashing, it’s quite serious.

Sadly we don’t have more feedback about this unofficial build, maybe it’s just a build issue and not a general /e/ issue.

I would recommend using the latest test build from this thread. The file is at available for download from AndroidFileHost

Hello Sideloaded, same error
but, The same error is in CM 16 CM17 etc. Always stuck with Settingsapp. how to debug?
Ho do I activate an ADB shell with this problem?

lineage 16/17 sry. Is there a way to reget the original sony image an start from there again?

There is. It involves the use of Xperifirm to get hold of the the stock firmware, and Sony Xperia FlashTool to flash it on your device. Useful guides here

and here

The guides may be focussed on Windows, but I have used Xperifim under Linux (using Mono) and FlashTool under both MacOS and Linux.

Helle Petefoth,

thanks for that, I am back on Stockrom now. But Wifi is not working though, and I think i found the reason:
The MAC Address get lost, displaying as: 02:00:00:00:00:00 which is bullshit.
The only workaround I ve found sofar is:

But how to get root now? Do you have a working description, like the ones above?


Sorry, I have no ideas or knowledge about this.

Hello Petefoth,

thanks for your help. I bought another (damaged) z3c and now i have e 0.10 installed and it is working like a charm so far. Now i need to build up one fully working smartphone with best parts of both. The only thing that i was doing different during the install procedure from linage OS was (https://wiki.lineageos.org/devices/z3c/install):
" * Now tap Wipe ." -> OK
“* Now tap Format Data and continue with the formatting process. This will remove encryption and delete all files stored in the internal storage.” -> NEVER DO THIS ON A SONY!!!
“* Return to the previous menu and tap Advanced Wipe , then select the Cache and System partitions and then Swipe to Wipe .” ->NO NEVER DO THIS ON A SONY!!!>
Instead: Just “SWIPE to Wipe” with default in Wipe Menu of TWRP (twrp 3.3.1) (Never “Advanced Wipe”)
And voila, Sideload /e/ and there you go.

May I help testing something to make z3c to a supported /e/ device?
And how to root /e/ for debugging?