E for FP2 adb help!

Hi everybody! Trying to install e/os in My old FP2 is running into problems. (Btw, I am a total rookie to all this)

  1. using terminal in Osx, i managed after some attempts to create a Path to the directory where the downloaded adb and fastboot was störd.
  2. could install twrp in device
  3. fastboot, recovery and enterd twrp
  4. wiped device
  5. started sideload om device and computer
    6)Fail! Returned error 7 in twrp
    7)can No longer use adb! Terminal returns “permission denied”

What now? How come THE adb suddenly stopped working?

Please help!

Regain your privacy! Adopt /e/ the unGoogled mobile OS and online servicesphone

Here’s a guide to really install from scratch … just follow steps 1 to 4 (or step 4 only if you can still boot into TWRP by keeping Volume + pressed while starting or rebooting the phone) and then try installing /e/ again …


Hi! Thank you for advice and Link. Will follow instructions and report back.

TWRP 3.4.0-0 is designed for android 10, for installing android 9,8,7 version, better use TWRP 3.3.1-0

Hi! Thank you for helping out. The permission problem was solved by changing computer and reinstall platform-tools. After downgrading to twrp (as recomended in Link for reinstalling fairphone os) i again first tried flashing e/os. And this time it worked perfectly.


Just a note for others perhaps reading along … The mentioned guide doesn’t recommend a specific TWRP version, it only says to download the current one. TWRP 3.2.3-0 is shown in the screenshots simply because it was the current version when the initial TWRP screenshots in the guide were made :wink: .

That being said, 3.2.3-0 has proven to be a reliable and stable workhorse on the Fairphone 2, I’m not a big fan of the 3.3 versions, which had their quirks, and I can’t say much about the relatively new 3.4.0-0.

1 Like